Closed Bug 1447781 Opened 3 years ago Closed 3 years ago

Switch off buildbot builds, was: All buildbot builds busted as of 2018-03-21

Categories

(Thunderbird :: Build Config, defect)

defect
Not set
blocker

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 61.0

People

(Reporter: jorgk-bmo, Unassigned)

References

Details

(Keywords: regression)

Attachments

(1 file)

First seen: Wed, Mar 21, 2018, 20:21:58:
https://treeherder.mozilla.org/#/jobs?repo=comm-central&revision=cc67b8f8435c6a3f93762e5fd6f28e390711afa9

make[2]: *** [configure] Error 1
make[1]: *** [/builds/slave/tb-c-cen-lx-000000000000000000/build/objdir-tb/Makefile] Error 2
make: *** [build] Error 2

Log
https://archive.mozilla.org/pub/thunderbird/tinderbox-builds/comm-central-win64/1521660160/comm-central-win64-bm71-build1-build14.txt.gz
says:

checking for llvm-config... not found
*** Fix above errors and then restart with\
               "c:/builds/moz2_slave/tb-c-cen-w64-00000000000000000/build/mozmake.exe -f client.mk build"
c:/builds/moz2_slave/tb-c-cen-w64-00000000000000000/build/client.mk:360: recipe for target 'configure' failed
mozmake.exe[2]: Leaving directory 'c:/builds/moz2_slave/tb-c-cen-w64-00000000000000000/build'
c:/builds/moz2_slave/tb-c-cen-w64-00000000000000000/build/client.mk:374: recipe for target 'c:/builds/moz2_slave/tb-c-cen-w64-00000000000000000/build/objdir-tb/Makefile' failed
mozmake.exe[1]: Leaving directory 'c:/builds/moz2_slave/tb-c-cen-w64-00000000000000000/build'
client.mk:217: recipe for target 'build' failed
ERROR: Could not find LLVM/Clang installation for compiling stylo build-time
bindgen.  Please specify the 'LLVM_CONFIG' environment variable
(recommended), pass the '--with-libclang-path' and '--with-clang-path'
options to configure, or put 'llvm-config' in your PATH.  Altering your
PATH may expose 'clang' as well, potentially altering your compiler,
which may not be what you intended.
mozmake.exe[2]: *** [configure] Error 1

M-C last good: 7b55d395bb63165c20a9230f82b3b14da0
M-C frist bad: 3aa5d07146382d41d317aa3fb81e68741d
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=7b55d395bb63165c20a9230f82b3b14da0&tochange=3aa5d07146382d41d317aa3fb81e68741d

I can't where this comes from, but it looks like LLVM and Stylo are now compulsory, maybe also on local builds.

Needless to say that without buildbot builds, there are no Dailies :-(
Flags: needinfo?(philipp)
Flags: needinfo?(mozilla)
Yeah, I'm not sure there is anything to do here.
Flags: needinfo?(mozilla)
Well, locally it still compiles without Stylo/LLVM.
I take that back :-(
BTW, caused by bug 1447358.
I think this is going to be WONTFIX.
Blocks: 1447358
Keywords: regression
OK, why don't we switch off the buildbot builds then. No need to have five of them fail on every push.
Comment on attachment 8961203 [details]
Bug 1447781: Disable buildbot builds on comm-central;

https://reviewboard.mozilla.org/r/229980/#review235678

While this succesfully removes all the compile + l10n jobs, it also drops 'TB Linux x86-64 comm-central periodic' builder which produces commits like https://hg.mozilla.org/comm-central/rev/df69b8b00e44. I'll r+ on the assumption that's the lesser issue right now but happy to look at an alternate patch if you want. Callek has been working on redoing the periodic file bumper for Firefox in taskcluster.
Attachment #8961203 - Flags: review?(nthomas) → review+
Comment on attachment 8961203 [details]
Bug 1447781: Disable buildbot builds on comm-central;

https://reviewboard.mozilla.org/r/229980/#review235678

I had definitely intended to leave the periodic file updates alone for now.

I think I've updated things so they are still done. (I even found the instructions for doing the builder diff this time).
Attachment #8961203 - Flags: review+ → review?(nthomas)
Comment on attachment 8961203 [details]
Bug 1447781: Disable buildbot builds on comm-central;

https://reviewboard.mozilla.org/r/229980/#review235928

This one seems to keep 'TB Linux x86-64 comm-central build' around, as the enable_dep needs to be set on the platform. r+ if you fix that up.
Attachment #8961203 - Flags: review?(nthomas) → review+
Flags: needinfo?(philipp)
Summary: All buildbot builds busted as of 2018-03-21 → Switch off buildbot builds, was: All buildbot builds busted as of 2018-03-21
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 61.0
You need to log in before you can comment on or make changes to this bug.