Closed Bug 1447995 Opened 4 years ago Closed 4 years ago

The length of time and seekbar for WebM videos is automatically modified

Categories

(Core :: Audio/Video: Playback, defect, P3)

defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox-esr52 --- wontfix
firefox59 --- wontfix
firefox60 --- fix-optional
firefox61 --- fix-optional

People

(Reporter: csasca, Unassigned)

Details

(Keywords: regression)

Attachments

(1 file)

Attached image bug.gif
[Affected versions]:
Latest Nightly 61.0a1 Build ID: 20180321220044
Firefox Beta 60.0b5
Firefox 59.0.1 RC

[Affected platforms]:
-Windows 10 (x64) 
-Windows 7 (x64) 
-Ubuntu 16.04 (x64) 
-macOS 10.12.6

[Steps to reproduce]:
1.Start Firefox
2.Open the link https://www.quirksmode.org/html5/videos/big_buck_bunny.webm
3.Right-Click on video and activate loop
4.Seek the video at the last seconds and observe the behavior.

[Expected result]:
The video starts from the beginning without any issue.

[Actual result]:
The video's time length and seekbar are doubled and only the first half of the seekbar is functional.

[Regression range]:
It seems that this is an old regression.
Last Good:2014-09-10
First Bad:2014-09-11
Pushlog: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=152ef25e89ae&tochange=98ea98c8191a

[Additional notes]:
-The issue is intermittent.
-The issue is reproducible without activating loop, but if it is activated, it is easier to spot the issue, as the video doesn't stop at the end.
-I found another issue with a Flac where after doing the same STR from above, the streaming starts from 0:40 seconds.
Here is the link for the Flac file under test (http://www.hyperion-records.co.uk/audiotest/18%20MacCunn%20The%20Lay%20of%20the%20Last%20Minstrel%20-%20Part%202%20Final%20chorus%20O%20Caledonia!%20stern%20and%20wild.FLAC)
I cannot reproduce this on Nightly 66. Assuming it has been fixed in the meantime, but I don't have the time to figure out what fixed it.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.