Closed Bug 1448146 Opened 2 years ago Closed 2 years ago

If HWA is disabled/blocked, Nightly is opened with black window flashed at start up.

Categories

(Firefox :: General, defect, P1)

61 Branch
x86_64
Windows 10
defect

Tracking

()

VERIFIED FIXED
Firefox 61
Tracking Status
firefox-esr52 --- unaffected
firefox59 --- unaffected
firefox60 --- unaffected
firefox61 + verified

People

(Reporter: alice0775, Assigned: florian)

References

Details

(Keywords: regression, Whiteboard: [fxperf:p1])

Attachments

(1 file)

This is annoying.

Reproducible : always

Steps To Reproduce:
1. Disable HWA
2. Close browser
3. Launch Nightly

Actual Results:
black window without UI is opened at start up.  And then switch to normal color.

Expected Results:
No black window at start up.

Regression window:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=e21a2a57d05dfe3c5ff8ba71131127fa781ffdd0&tochange=f026ead5dbfce9d6530429ac568ecc5544cc9b3b

Regressed by: f026ead5dbfc	Florian Quèze — Bug 1447719 - Set browser.startup.blankWindow to true on Windows and Linux, r=mconley.


And I confirmed that setting browser.startup.blankWindow = false fixed the problem


@:florian,
Your patch seems to cause the regression. Can you look into this?
Flags: needinfo?(florian)
How do you disable HWA?
Summary: If HWA is disabled, Nightly is opened with black window at start up. → If HWA is disabled, Nightly is opened with black window flashed at start up.
(In reply to Florian Quèze [:florian] from comment #1)
> How do you disable HWA?

1. about:preferences > General > Performance
2. Uncheck "Use recommended performance setting"
3. Uncheck "Use hardware acceleration when available"

OR
1. Using Blocked old GPU card.
Summary: If HWA is disabled, Nightly is opened with black window flashed at start up. → If HWA is disabled/blocked, Nightly is opened with black window flashed at start up.
I'm experiencing this black flash on Firefox start even with Hardware Acceleration enabled.

Setting "browser.startup.blankWindow" preference to "false" fixes it, as workaround,
but it's making bug #1446264 back at start.
(In reply to Alice0775 White from comment #4)
> Created attachment 8961655 [details]
> black_window_is_flashing_at_startup.ogg (runninng Nightly on VM)

Startup is so slow in this video that IMO showing a black window is better there than having no visual feedback that Firefox is starting.

(In reply to Alice0775 White from comment #2)
> (In reply to Florian Quèze [:florian] from comment #1)
> > How do you disable HWA?
> 
> 1. about:preferences > General > Performance
> 2. Uncheck "Use recommended performance setting"
> 3. Uncheck "Use hardware acceleration when available"

Interesting, this sets the layers.acceleration.disabled pref to true. When I do that, at startup I get a white window, followed by a black flash and then by the browser UI appearing. This is very ugly :(.

If I also set layers.gpu-process.enabled to false, I don't get the white window before the black paint.

(In reply to Virtual_ManPL [:Virtual] from comment #3)
> I'm experiencing this black flash on Firefox start even with Hardware
> Acceleration enabled.

This is probably a separate bug with a missing step to reproduce (sounds similar to bug 1447549 comment 5 which I'm not able to reproduce). I can reproduce the black flash if I follow the steps from comment 2.
Whiteboard: [fxperf:p1]
The video of comment#5 is on vm(blocked GPU).
The behavior might be different between |disabled HWA on non-blocked GPU| and |blocked GPU|.
(In reply to Alice0775 White from comment #6)
> The video of comment#5 is on vm(blocked GPU).
> The behavior might be different between |disabled HWA on non-blocked GPU|
> and |blocked GPU|.

Makes sense; I would expect us to not start a gpu process is the GPU is blocked.
This is an [fxperf:p1] - should we assign this to you, florian?
Flags: needinfo?(florian)
Florian, will bug 1450293 fix this?
Assignee: nobody → florian
Status: NEW → ASSIGNED
Depends on: 1450293
Priority: -- → P1
(In reply to Panos Astithas [:past] (please ni?) from comment #9)
> Florian, will bug 1450293 fix this?

This bug is marked as affecting Windows, and the current patch in bug 1450293 fixes it for Windows, so "yes". But bug 1450408 comment 0 says the black flash also occurs on Linux, so "not sure".
Status?
Flags: needinfo?(florian)
(In reply to Marion Daly [:mdaly] from comment #11)
> Status?

Fixed in bug 1450293, at least for Windows.
Flags: needinfo?(florian)
Alice, can you confirm that things are looking better on your end?
Flags: needinfo?(alice0775)
yes, at least for Windows, it was fixed.

However, I can still reproduce the black flashing on startup on Linux(ubuntu16.04 and Linux MINT).
Flags: needinfo?(alice0775)
(In reply to Alice0775 White from comment #14)
> yes, at least for Windows, it was fixed.
> 
> However, I can still reproduce the black flashing on startup on
> Linux(ubuntu16.04 and Linux MINT).

just now updated nightly, no longer reproduce on linux too.
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Thanks for confirming!
Target Milestone: --- → Firefox 61
I verified on Firefox 61.0b6 and Nightly (2018-05-20) under Windows 10 (x64) and macOS 10.12 and the issue is fixed. However on Ubuntu 16.04 (x64), the black window at startup is present, even without HWA disabled. Firefox 60 is unaffected on all three systems. Here is a screencast: https://drive.google.com/open?id=1OBLSto7Si1w-ln7jtEAU7dkjpkdVDjJV

Hi Jim, since Florian is currently unavailable, I'd like to know what you think about this issue on Ubuntu?
Flags: needinfo?(jmathies)
(In reply to Sasca Catalin, QA [:csasca] from comment #17)

The issue on Ubuntu is covered by bug 1450626.
Flags: needinfo?(jmathies)
Considering the comments from above, this issue can be closed as the Ubuntu issue is being covered by bug 1450626.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.