Make the DisplayBookmarksBar and DisplayMenuBar policies support both true or false params

RESOLVED FIXED in Firefox 60

Status

()

defect
RESOLVED FIXED
a year ago
a year ago

People

(Reporter: Felipe, Assigned: Felipe)

Tracking

unspecified
Firefox 61
Points:
---

Firefox Tracking Flags

(firefox60+ fixed, firefox61 fixed)

Details

Attachments

(1 attachment)

Currently these policies only support `true`, but with the runOncePerModification helper, it's easy to make them support `false` too, which will make them more dynamic.

[Tracking Requested - why for this release]:
Small improvement to two policies
Summary: Make DisplayBookmarksBar and DisplayMenuBar policy support both true or false params → Make the DisplayBookmarksBar and DisplayMenuBar policies support both true or false params

Comment 2

a year ago
mozreview-review
Comment on attachment 8961609 [details]
Bug 1448198 - Make the DisplayBookmarksBar and DisplayMenuBar policies support both true and false params.

https://reviewboard.mozilla.org/r/230476/#review236182

Looks good to me.
Attachment #8961609 - Flags: review?(ksteuber) → review+

Comment 3

a year ago
Pushed by felipc@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/cfa3815beea0
Make the DisplayBookmarksBar and DisplayMenuBar policies support both true and false params. r=bytesized
Tests, they work!

The logic is inverted for this policy: when the param is true, it should add collapsed="false". It worked properly with the hardcoded "false", but my patch didn't get this right
Flags: needinfo?(felipc)
Comment hidden (mozreview-request)

Comment 7

a year ago
Pushed by felipc@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/0aa1396dff4c
Make the DisplayBookmarksBar and DisplayMenuBar policies support both true and false params. r=bytesized

Comment 8

a year ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/0aa1396dff4c
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 61
Comment on attachment 8961609 [details]
Bug 1448198 - Make the DisplayBookmarksBar and DisplayMenuBar policies support both true and false params.

Approval Request Comment
[Feature/Bug causing the regression]: Enterprise policies for displaying the bookmarks toolbar and menu bar
[User impact if declined]: These two policies only supported displaying the bookmarks and menu bar (because they are not displayed by default). This change allows the policy to also hide them if they have been previously displayed. This means the sysadmin has more control and can tweak this setting as time goes by to true or false as they need.
[Is this code covered by automated tests?]: yes
[Has the fix been verified in Nightly?]: no
[Needs manual test from QE? If yes, steps to reproduce]: no
[List of other uplifts needed for the feature/fix]: no
[Is the change risky?]: no
[Why is the change risky/not risky?]: very small change, covered by tests
[String changes made/needed]: none
Attachment #8961609 - Flags: approval-mozilla-beta?
Comment on attachment 8961609 [details]
Bug 1448198 - Make the DisplayBookmarksBar and DisplayMenuBar policies support both true and false params.

policies fix, beta60+, should be in 60.0b8
Attachment #8961609 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.