Cookie Panel - new sidebar component to support informed consent with cookies

RESOLVED WONTFIX

Status

()

Core
Networking: Cookies
--
enhancement
RESOLVED WONTFIX
16 years ago
14 years ago

People

(Reporter: Alex Quinn, Assigned: Alex Quinn)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Assignee)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0rc2)
Gecko/20020510
BuildID:    2002051006

I've posted a page specifically for this bug report at...
http://www.washington.edu/homes/aquinn/mozilla/

Here's the summary:
This is an extension to Mozilla that provides a sidebar which gives the user
real-time information about the cookies that are being set. This is an effort to
support informed consent with cookies. The idea is that if the user is aware of
the cookies and gets some qualitative information about them, then they may be
able to make more informed decisions about how to set browser cookie policies,
when and which cookies to delete, and which sites they may want to avoid
altogether. This is the result of a research project with Value Sensitive Design
at the University of Washington, led by Batya Friedman, an associate professor
in the School of Information.  Development work is being done by Alex Quinn, the
student submitting this report.  Development is being done on both Linux and NT.

The code is not finished.  There are some significant issues that need to be
addressed.  We just want to get some feedback to we can make sure our efforts
are in synch with the rest of the Mozilla project.

I discussed all of this with Steve Morse over the phone a couple weeks ago.

Reproducible: Always
Steps to Reproduce:
This is a new feature.  Directions for installing it are at the web page
referenced above.

Here's a link to a screen shot...
http://alexquinn.org/mozilla/moz-screen.png

Comment 1

16 years ago
Your ideas here sound excellent.  Unfortunately neither of your two links are 
accessible.  They might be inside your firewall.

The http://www.washington.edu/homes/aquinn/mozilla/ link give me a URL Not Found 
error message.  The http://alexquinn.org/mozilla/moz-screen.png link times out.

Could you please include these as attachments instead.
(Assignee)

Comment 2

16 years ago
There was a typo in the body.  The link in the URL field above should work.  The
correct link is...
 http://www.cs.washington.edu/homes/aquinn/mozilla/

Comment 3

16 years ago
Alex, this looks really interesting... 

I'd like to suggest that you set up a project at mozdev.org to get the code out
there and to let other people see it in action. It seems unlikely having seen
all sort of cool stuff being floated that this could get into mozilla-proper
without having either been developed in-NS and NS backed or without large
community support. The way to get that it to show it off!

Like I said I think your best bet for getting this used is an installable xpi at
mozdev so that people can see whats there. - But then I'm just a humble
occasional QA and general hanger-on

Comment 4

16 years ago
No, the way to get this checked in is first to finish it and second to post a 
patch.  At that time you'll need to get it reviewed (I'll do the review) and 
super-reviewed.

It doesn't have to have been developed in netscape in order to get checked in.

Comment 5

16 years ago
Confirmed. See also bug 42663.

The trick, of course, is to make the UI commensurate with the perceived 
importance of the feature. I doubt that anyone will want to keep the sidebar 
open (causing the Web page to scroll horizontally) just to have fine-grained 
control over cookies, when few people even understand what cookies are.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 6

15 years ago
alex: great work!

so have you submitted this as a mozdev project, or are you hoping to get it in
the tree?

Comment 7

14 years ago
see Bug 227475 for completing the audit trail with the port a cookie came from
okay, so any code that exists is probably horribly bitrotted.  I don't intend to
implement anything like this in my lifetime... WONTFIX or reassign to
nobody@mozilla.org and Future?

For the sake of the component being stuff we think should be done, my vote is
for the former.  dwitte?
QA Contact: tever → cookieqa

Comment 9

14 years ago
-> wontfix, since the assignee hasn't demonstrated any active involvement in the
development of this feature for quite some time; and it's something that I think
would be better off as an extension (e.g. mozdev material) rather than
distributed with the browser. A nice feature for power users, or those doing
website development involving cookies, but I agree with mpt's & mconnor's
opinions here wrt being default-build material.

(if anyone does want to pick this up and take it to mozdev, fwiw i doubt the
code is significantly bitrotted - it probably mostly uses the frozen
nsICookieManager interface.)
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WONTFIX
(Assignee)

Comment 10

14 years ago
I'll see if I can get this working with a recent build and reopen the bug when 
that happens.

Last time I worked on this, I had it working smoothly with 1.2 but I felt it 
needed some enhancements in order to fulfill users' expectations.  For example, 
users probably expect cookies to have a context menu capable of performing basic 
operations, minimally Delete and Properties.  I didn't have time to do it then.
Alex, I think Dan's point is that this really isn't something that would be a
core feature, it'd be best to establish a mozdev project and distribute it as an
extension.
Yes, I'd also like to see this as a mozdev project. It seems like it should be
easy to start a new project, and you will get web space, CVS repository and bug
database for the project. See http://www.mozdev.org/start.html
You need to log in before you can comment on or make changes to this bug.