Closed Bug 1448473 Opened 2 years ago Closed 2 years ago

dark theme: hover style is missing in menus on macOS (regression)

Categories

(Firefox :: Theme, defect, P1)

defect

Tracking

()

RESOLVED FIXED
Firefox 61
Tracking Status
firefox-esr52 --- unaffected
firefox59 --- unaffected
firefox60 --- fixed
firefox61 --- fixed

People

(Reporter: soeren.hentzschel, Assigned: ntim)

References

Details

(Keywords: regression)

Attachments

(2 files)

Bug 1408121 made that the dark theme also applies to the menus in Firefox. But there is an usability regression, at least on macOS: the hover style is missing on menu items. It still works for the default theme and for the light theme.
Duplicate of this bug: 1448470
Connor can you take a look at this when you get a chance?
Flags: needinfo?(masinico)
Priority: -- → P1
I think it's easier to fix bug 1417883 first.
Assignee: nobody → ntim.bugs
Status: NEW → ASSIGNED
Taking this one.
Flags: needinfo?(masinico)
Maybe related: the "Search for {term} with {search provider icons}"-bar is also black instead of grey.
I've used the Windows and Linux values for arrowpanel-dimmed-* since they seem to already be adjusted for this purpose.

I also adjusted panel-separator-color on [lwt-popup-brighttext].
Comment on attachment 8963301 [details]
Bug 1448473 - Adjust panel variables to work well on dark themes.

https://reviewboard.mozilla.org/r/232208/#review237864
Attachment #8963301 - Flags: review?(dao+bmo) → review+
Blocks: 1449616
Pushed by ntim.bugs@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/ca73bbba52d3
Adjust panel variables to work well on dark themes. r=dao
Comment on attachment 8963301 [details]
Bug 1448473 - Adjust panel variables to work well on dark themes.

Approval Request Comment
[Feature/Bug causing the regression]: Bug 1417880
[User impact if declined]: Bad visibility of hover/active states when using a theme that styles the application menu like https://addons.mozilla.org/en-GB/firefox/addon/arc-dark-theme-webextension/

[Is this code covered by automated tests?]: no
[Has the fix been verified in Nightly?]: not yet
[Needs manual test from QE? If yes, steps to reproduce]: no
[List of other uplifts needed for the feature/fix]: none
[Is the change risky?]: no, low risk change
[Why is the change risky/not risky?]: CSS only
[String changes made/needed]: no
Attachment #8963301 - Flags: approval-mozilla-beta?
Attached patch Patch for betaSplinter Review
Attachment #8963301 - Flags: approval-mozilla-beta?
Comment on attachment 8963671 [details] [diff] [review]
Patch for beta

See comment 10.
Attachment #8963671 - Flags: approval-mozilla-beta?
https://hg.mozilla.org/mozilla-central/rev/ca73bbba52d3
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 61
Comment on attachment 8963671 [details] [diff] [review]
Patch for beta

Minor OSX theme fix. Approved for 60.0b9.
Attachment #8963671 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
QA Whiteboard: [good first verify]
You need to log in before you can comment on or make changes to this bug.