Closed Bug 1448523 Opened 2 years ago Closed 2 years ago

Perma-orange devtools/client/debugger/new/test/mochitest/browser_dbg-babel-preview.js | This test exceeded the timeout threshold. It should be rewritten or split up. If that's not possible, use requestLongerTimeout(N), but only as a last resort. -

Categories

(DevTools :: Debugger, defect, P5)

defect

Tracking

(firefox61 fixed)

RESOLVED FIXED
Firefox 61
Tracking Status
firefox61 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: sparky)

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

Filed by: ncsoregi [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=169995075&repo=mozilla-central

https://queue.taskcluster.net/v1/task/U4O-qatYTe-eeJqWVUpCWw/runs/0/artifacts/public/logs/live_backing.log

23:48:14     INFO -  277 INFO Waiting for event: 'TabClose' on [object XULElement].
23:48:14     INFO -  Buffered messages logged at 23:48:14
23:48:14     INFO -  278 INFO Got event: 'TabClose' on [object XULElement].
23:48:14     INFO -  279 INFO Tab removed and finished closing
23:48:14     INFO -  Buffered messages finished
23:48:14    ERROR -  280 INFO TEST-UNEXPECTED-FAIL | devtools/client/debugger/new/test/mochitest/browser_dbg-babel-preview.js | This test exceeded the timeout threshold. It should be rewritten or split up. If that's not possible, use requestLongerTimeout(N), but only as a last resort. -
23:48:14     INFO -  GECKO(3236) | MEMORY STAT | vsize 2382MB | vsizeMaxContiguous 131939739MB | residentFast 499MB | heapAllocated 134MB
23:48:14     INFO -  281 INFO TEST-OK | devtools/client/debugger/new/test/mochitest/browser_dbg-babel-preview.js | took 95509ms
23:48:14     INFO -  GECKO(3236) | ++DOCSHELL 000001626B158800 == 2 [pid = 572] [id = {8a0e3b06-3591-48da-bbb2-cf9dc6b4692b}]
23:48:14     INFO -  GECKO(3236) | ++DOMWINDOW == 3 (000001627303C400) [pid = 572] [serial = 8] [outer = 0000000000000000]
23:48:14     INFO -  GECKO(3236) | ++DOMWINDOW == 4 (0000016273048400) [pid = 572] [serial = 9] [outer = 000001627303C400]
23:48:15     INFO -  GECKO(3236) | ++DOMWINDOW == 5 (000001627322E400) [pid = 572] [serial = 10] [outer = 000001627303C400]
23:48:15     INFO -  282 INFO checking window state
Thanks for doing this!  we can now see where this started- unfortunately there are other failures in the same job so we need to examine all orange jobs carefully.

this is the set of commits where this started:
https://hg.mozilla.org/mozilla-central/pushloghtml?changeset=6c82708c26ee0e21142c78d9c031723f32fce3fd

it was intermittent there- vs perma fail elsewhere- maybe this is a timing issue or it became worse later on.

unfortunately this is a job that can only be run on mozilla-central or try- which means we cannot backfill data on autoland.  Maybe :jlast sees something in the 64 commits linked in this comment which could be the root cause.
Flags: needinfo?(jmaher) → needinfo?(jlaster)
this jumps out at me:

Nicolas Chevobbe — Bug 1447715 - Remove old-event-emitter usage from sourceeditor; r=gl.
Flags: needinfo?(jlaster)
I dont recognize anything else, could we bisect this and narrow it down a bit?
Flags: needinfo?(jlaster)
I did a bisection and the test wasn't being run- I had incorrectly analyzed the retriggers and had found babel_scopes.js and not babel_preview.js- so this is the new range:
https://hg.mozilla.org/mozilla-central/pushloghtml?changeset=9cb650de48f9339b8b1499aeb9fe68f15f122aa2

and the test was introduced in that range from Bug 1447682.

:jlast, that was added by you according to hg- would you be able to help solve this?
Flags: needinfo?(jlaster)
I think we should disable the test for windows10-64-ccov
Flags: needinfo?(jlaster)
:sparky- up for making a patch for this?
Flags: needinfo?(gmierz2)
Comment on attachment 8965779 [details]
Bug 1448523 - Disable browser_dbg-babel-preview.js on windows10-64-ccov.

https://reviewboard.mozilla.org/r/234606/#review240266

thanks!
Attachment #8965779 - Flags: review?(jmaher) → review+
Flags: needinfo?(gmierz2)
Keywords: checkin-needed
Pushed by jmaher@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8885206a9224
Disable browser_dbg-babel-preview.js on windows10-64-ccov. r=jmaher
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/8885206a9224
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 61
Assignee: nobody → gmierz2
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.