Missing exit full-screen button for videos

VERIFIED FIXED in Firefox 61

Status

()

defect
VERIFIED FIXED
a year ago
a year ago

People

(Reporter: winson.wen1, Assigned: timdream)

Tracking

({regression})

Firefox 61
Firefox 61
All
Android
Points:
---

Firefox Tracking Flags

(firefox59 unaffected, firefox60 unaffected, firefox61 verified)

Details

Attachments

(1 attachment)

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:61.0) Gecko/20100101 Firefox/61.0
Build ID: 20180323221725

Steps to reproduce:

Open a video in Firefox
Press the full-screen button


Actual results:

The exit full-screen button icon is missing. Tapping where it should be still works to exit full-screen.


Expected results:

Icon is present.
(Reporter)

Comment 1

a year ago
Possibly related to Bug 1444489?
Seems likely.
Status: UNCONFIRMED → NEW
Component: General → Audio/Video
Ever confirmed: true
Flags: needinfo?(timdream)
Keywords: regression
OS: Unspecified → Android
Hardware: Unspecified → All
Thank you for filing the bug. I most have broken my own patch while histedit the changesets ...

This can be fixed by listing fullscreenExitButton.svg in the mobile jar.mn. I will submit a patch soon.
Assignee: nobody → timdream
Blocks: 1444489
Status: NEW → ASSIGNED
Flags: needinfo?(timdream)

Comment 5

a year ago
FWIW, I reported this bug on 1379389. No one could reproduce it. The latest version of Firefox Android where ALL fullscreen controls were drawn properly in desktop mode was 47. Starting with 48, a control in the upper right (info control?) was improperly drawn and the problem got progressively worse (no exit full screen, no settings icon).
(In reply to Ken Riley from comment #5)
> FWIW, I reported this bug on 1379389. No one could reproduce it. The latest
> version of Firefox Android where ALL fullscreen controls were drawn properly
> in desktop mode was 47. Starting with 48, a control in the upper right (info
> control?) was improperly drawn and the problem got progressively worse (no
> exit full screen, no settings icon).

Your bug is unrelated to this one because you are talking about controls implemented by YouTube themselves. We are working on controls offered in Firefox natively here.

Comment 7

a year ago
mozreview-review
Comment on attachment 8962121 [details]
Bug 1448528 - Include fullscreenExitButton.svg in mobile package

https://reviewboard.mozilla.org/r/230964/#review236584

D'oh. r=me. I wish we had a fix for bug 1422041, which I think might have caught this.
Attachment #8962121 - Flags: review?(gijskruitbosch+bugs) → review+

Comment 8

a year ago
Pushed by timdream@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/89a60060413f
Include fullscreenExitButton.svg in mobile package r=Gijs

Comment 9

a year ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/89a60060413f
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 61

Comment 10

a year ago
Verified as fixed on Nightly 61.0a1 (2018-04-01) using Huawei M3 Lite 10 Tablet (Android 7.0) and Google Pixel XL (Android 8.1.0)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.