Consider unprefixing ::-moz-selection for web compat

RESOLVED DUPLICATE of bug 509958

Status

()

enhancement
RESOLVED DUPLICATE of bug 509958
a year ago
a year ago

People

(Reporter: fvsch, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(firefox61 affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

a year ago
While the spec (https://www.w3.org/TR/css-pseudo-4/#highlight-pseudos) is not finalized yet, many sites include ::selection styles which work for text color and background color in:

- IE9+
- Edge
- Chrome
- Safari

Firefox is the only holdout with support for a prefixed version only. While having it prefixed (or better, behind a flag) is the theoretical good approach, in practice it’s a web compat issue since ::selection is widely used on the Web, with two scenarios for Firefox:

1. ::-moz-selection is not included
2. ::-moz-selection is included but not updated, resulting in issues like hard to read or even *invisible* selections (Example: https://github.com/react-navigation/react-navigation.github.io/pull/41)

Would unprefixing ::-moz-selection as-is doable at all?
Cheers.
I suggested the same in bug 1427680. I'm happy to do it, though that is still waiting on input from dbaron.

Friendly reminder :)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(dbaron)
See Also: → 1427680
(Reporter)

Comment 2

a year ago
This screenshot shows a common issue with the lack of ::selection support: sites that use text-shadow for visual effects (in this case for mimicking text-decoration-skip-ink:auto) will remove the text-shadow on ::selection but often don't duplicate this style specifically for Firefox.
(Reporter)

Comment 3

a year ago
Woops, looks like this is a duplicate of bug 509958.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 509958
That bug does have way more context. Thanks!
Flags: needinfo?(dbaron)
You need to log in before you can comment on or make changes to this bug.