Closed Bug 1449143 Opened 2 years ago Closed 2 years ago

Linux and Windows debug build failures on 2017-03-27: testing/xpcshell/selftest.py::XPCShellTestsTests::testAddTaskSkip TEST-UNEXPECTED-FAIL, also: Massive Xpcshell test failures

Categories

(Thunderbird :: General, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 61.0

People

(Reporter: jorgk-bmo, Unassigned)

References

Details

(Whiteboard: [Thunderbird-testfailure: BX all debug only][Thunderbird-temporary-fix])

Attachments

(1 file)

Log says:
https://taskcluster-artifacts.net/FAyw6bd5ToOEeYmfB77XkA/0/public/logs/live_backing.log
INFO - E   PID 8717 | \x07[8717, Main Thread] ###!!! ASSERTION: 'network.auth.subresource-img-cross-origin-http-auth-allow' already registered
INFO - E   PID 8717 | : 'Error', file /builds/worker/workspace/build/src/modules/libpref/Preferences.cpp, line 5013

The Xpcshell test failures also say:
INFO -  PID 3828 | \x07[3828, Main Thread] ###!!! ASSERTION: 'network.auth.subresource-img-cross-origin-http-auth-allow' already registered
INFO -  PID 3828 | : 'Error', file /builds/worker/workspace/build/src/modules/libpref/Preferences.cpp, line 5013

Maybe caused by bug 1436655. Nicholos, could you shed some light onto this.

Also see:
https://dxr.mozilla.org/comm-central/search?q=network.auth.subresource-img-cross-origin-http-auth-allow&redirect=false

As far as I know, that's not the only preference we define again to override.
Flags: needinfo?(n.nethercote)
Whiteboard: [Thunderbird-testfailure: BX all debug only]
Nicholas (sorry about the typo in the previous comment), I've looked through your changes and found
https://hg.mozilla.org/mozilla-central/rev/16ac5bd4e50c#l5.36

pref("network.auth.subresource-http-auth-allow", 2);
pref("network.auth.subresource-img-cross-origin-http-auth-allow", false);
pref("network.auth.non-web-content-triggered-resources-http-auth-allow", false);

were removed, but we set the latter two in all-thunderbird.js:

// To allow images to be inserted into a composition with an auth prompt, we
// need the following two.
pref("network.auth.subresource-img-cross-origin-http-auth-allow", true);
pref("network.auth.non-web-content-triggered-resources-http-auth-allow", true);

So is there a new mechanism to set those prefs? Do we need to remove the pref() and set them programmatically somewhere in our start-up code now?
Keywords: leave-open
Whiteboard: [Thunderbird-testfailure: BX all debug only] → [Thunderbird-testfailure: BX all debug only][Thunderbird-temporary-fix]
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/0dcc75169b10
Temporarily not setting network.auth.* preferences to avoid asserts. rs=bustage-fix CLOSED TREE
Apologies for the bustage. This new checking simply isn't compatible with Thunderbird's overriding of these prefs, so I will disable it. I've filed bug
Blocks: 1436655
Flags: needinfo?(n.nethercote)
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/7bfc5aa5393a
Backed out changeset 0dcc75169b10 for being a temporary fix. a=backout
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 61.0
You need to log in before you can comment on or make changes to this bug.