Sort listeners by event name in the listener list

RESOLVED FIXED in Firefox 62

Status

enhancement
P2
normal
RESOLVED FIXED
Last year
Last year

People

(Reporter: kats, Assigned: miker)

Tracking

57 Branch
Firefox 62

Firefox Tracking Flags

(firefox62 fixed)

Details

Attachments

(1 attachment)

Component: Developer Tools → Developer Tools: Inspector
Mike, this might be something for you, if you have some time.
Severity: normal → enhancement
Flags: needinfo?(mratcliffe)
Priority: -- → P2
Assignee: nobody → mratcliffe
Status: NEW → ASSIGNED
Flags: needinfo?(mratcliffe)
Has Regression Range: --- → irrelevant
Has STR: --- → irrelevant
OS: Unspecified → All
Hardware: Unspecified → All
The HTML node contains a combination of window listeners, document listeners and document element listeners because we have nowhere else to display window and document listeners.

Sorting them is very easy so I will do that now.
Comment hidden (mozreview-request)

Comment 4

Last year
mozreview-review
Comment on attachment 8980623 [details]
Bug 1449232 - Sort listeners by event name in the listener list

https://reviewboard.mozilla.org/r/246774/#review252924
Attachment #8980623 - Flags: review?(pbrosset) → review+
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)

Comment 7

Last year
Pushed by mratcliffe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c88026f3d867
Sort listeners by event name in the listener list r=pbro
https://hg.mozilla.org/mozilla-central/rev/c88026f3d867
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 62

Updated

Last year
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.