Get rid of StyleSetHandle

RESOLVED FIXED in Firefox 61

Status

()

enhancement
RESOLVED FIXED
Last year
Last year

People

(Reporter: xidorn, Assigned: xidorn)

Tracking

Trunk
mozilla61
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox61 fixed)

Details

Attachments

(5 attachments)

No description provided.
Assignee: nobody → xidorn+moz
Depends on: 1447828
It is much much more involving than I would have thought.

The biggest problem here is that, the removal of StyleSetHandle changes include order of some headers, and uncovers many cycle includes.
Depends on: 1449798
Comment on attachment 8963480 [details]
Bug 1449400 part 1 - Move NS_STYLE_* constants from nsStyleStruct.h to ComputedStyle.h.

https://reviewboard.mozilla.org/r/232418/#review237820
Attachment #8963480 - Flags: review?(emilio) → review+
Comment on attachment 8963481 [details]
Bug 1449400 part 2 - Remove some dependencies from ServoStyleSet.h and add some random stuff to fix breakage.

https://reviewboard.mozilla.org/r/232420/#review237824
Attachment #8963481 - Flags: review?(emilio) → review+
Comment on attachment 8963482 [details]
Bug 1449400 part 3 - Remove ServoStyleSet::RecordStyleSheetChange and its trivial callsites.

https://reviewboard.mozilla.org/r/232422/#review237826
Attachment #8963482 - Flags: review?(emilio) → review+
Comment on attachment 8963483 [details]
Bug 1449400 part 4 - Split some inline functions from ServoStyleSet.h into an Inlines header.

https://reviewboard.mozilla.org/r/232424/#review237828
Attachment #8963483 - Flags: review?(emilio) → review+
Hmmm... actually it seems GCC doesn't like StyleSet() method... Maybe we have to stick with ServoStyleSet as the type name.
Comment on attachment 8963484 [details]
Bug 1449400 part 5 - Remove StyleSetHandle.

https://reviewboard.mozilla.org/r/232426/#review237868

Looks great, thank you! Maybe change the commit message to remove the rename bit that didn't happen in the end?

The AsServo on the stylesheets look indeed somewhat unfortunate, but they can go away in the future, so...
Attachment #8963484 - Flags: review?(emilio) → review+
We're sorry, Autoland could not rebase your commits for you automatically. Please manually rebase your commits and try again.

hg error in cmd: hg rebase -s ddb9402db74db5744b5fdd70c467a8425f6c1c45 -d 0f08cc27225c: rebasing 455008:ddb9402db74d "Bug 1449400 part 1 - Move NS_STYLE_* constants from nsStyleStruct.h to ComputedStyle.h. r=emilio"
rebasing 455009:984aa950b2a0 "Bug 1449400 part 2 - Remove some dependencies from ServoStyleSet.h and add some random stuff to fix breakage. r=emilio"
rebasing 455010:117f42a0d316 "Bug 1449400 part 3 - Remove ServoStyleSet::RecordStyleSheetChange and its trivial callsites. r=emilio"
rebasing 455011:8f845adad6ea "Bug 1449400 part 4 - Split some inline functions from ServoStyleSet.h into an Inlines header. r=emilio"
rebasing 455012:7741b1d222da "Bug 1449400 part 5 - Remove StyleSetHandle. r=emilio" (tip)
merging dom/base/nsDocument.cpp
merging dom/base/nsIDocument.h
merging dom/html/nsHTMLDocument.cpp
merging layout/base/nsLayoutUtils.cpp
merging layout/forms/nsComboboxControlFrame.cpp
merging layout/forms/nsTextControlFrame.cpp
merging layout/generic/nsImageFrame.cpp
merging layout/generic/nsTextFrame.cpp
merging layout/style/StyleSheet.cpp
merging layout/xul/nsListBoxBodyFrame.cpp
warning: conflicts while merging layout/xul/nsListBoxBodyFrame.cpp! (edit, then use 'hg resolve --mark')
unresolved conflicts (see hg resolve, then hg rebase --continue)
Pushed by xquan@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a812abeb4c76
part 1 - Move NS_STYLE_* constants from nsStyleStruct.h to ComputedStyle.h. r=emilio
https://hg.mozilla.org/integration/autoland/rev/687011f7c64c
part 2 - Remove some dependencies from ServoStyleSet.h and add some random stuff to fix breakage. r=emilio
https://hg.mozilla.org/integration/autoland/rev/f151de3f2e3a
part 3 - Remove ServoStyleSet::RecordStyleSheetChange and its trivial callsites. r=emilio
https://hg.mozilla.org/integration/autoland/rev/ed1fbd7316f4
part 4 - Split some inline functions from ServoStyleSet.h into an Inlines header. r=emilio
https://hg.mozilla.org/integration/autoland/rev/c5dd20c83088
part 5 - Remove StyleSetHandle. r=emilio
Duplicate of this bug: 1447826
You need to log in before you can comment on or make changes to this bug.