Sometimes vertical borders of buttons are not removed when focus is lost

RESOLVED DUPLICATE of bug 1349646

Status

()

defect
P3
normal
RESOLVED DUPLICATE of bug 1349646
Last year
Last year

People

(Reporter: mantaroh, Unassigned)

Tracking

(Blocks 1 bug, {reproducible, testcase})

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox61 affected)

Details

(Whiteboard: [gfx-noted])

Attachments

(2 attachments)

Gecko doesn't remove the solid border of a button element in the devtools menu button.

STR:
 1. Open the devtool.
 2. Select any toolbar button. (e.g. Inspector)
    (Note that some tool panel steals the focus. If lost the focus of button, refocus to the button.)
 3. Press the right arrow key.
 4. Repeat the step 3.

AR: A solid border has remained.
ER: The unfocused solid border of a button is removed.

An attachment file is another test case, the result is same. (i.e. border has remained.)
I think this problem isn't limited to border-style: solid but can be reproduced with other border styles.

Using attachment 8963009 [details] I notice that at least on Windows I need to press Tab once to focus the element before I can reproduce. (That is, the dotted line from the focus styles interfere somehow.)
Summary: A solid border of the button element is not removed. → Sometimes vertical borders of buttons are not removed when focus is lost
Priority: -- → P3
Whiteboard: [gfx-noted]
Flags: needinfo?(hikezoe)
I think this is a dup of bug 1349646.
Flags: needinfo?(hikezoe)
This doesn't happen on Firefox 52, I am pretty sure this is a dup of bug 1349646.
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → DUPLICATE
Duplicate of bug: 1349646
You need to log in before you can comment on or make changes to this bug.