Closed Bug 1449477 Opened 2 years ago Closed Last year

Port the previous test cases that have not been tested in new animation inspector

Categories

(DevTools :: Inspector: Animations, enhancement, P3)

enhancement

Tracking

(firefox62 fixed, firefox63 fixed)

RESOLVED FIXED
Firefox 63
Tracking Status
firefox62 --- fixed
firefox63 --- fixed

People

(Reporter: daisuke, Assigned: daisuke)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

The pseudo element test will added in bug 1450526.
Status: NEW → ASSIGNED
Priority: -- → P3
Product: Firefox → DevTools
Comment on attachment 8987424 [details]
Bug 1449477: Add test for short duration.

https://reviewboard.mozilla.org/r/252660/#review259206

::: devtools/client/inspector/animation/test/browser_animation_short-duration.js:1
(Diff revision 1)
> +"use strict";

Missing license

::: devtools/client/inspector/animation/test/browser_animation_short-duration.js:3
(Diff revision 1)
> +"use strict";
> +
> +// Test for short duration.

Can we be more descriptive here? 

It looks like we are testing for animations with short duration appearing in the summary graph along with its iteration path..
Attachment #8987424 - Flags: review?(gl) → review+
Comment on attachment 8987424 [details]
Bug 1449477: Add test for short duration.

https://reviewboard.mozilla.org/r/252660/#review259206

> Missing license

Indeed, thanks Gabriel!

> Can we be more descriptive here? 
> 
> It looks like we are testing for animations with short duration appearing in the summary graph along with its iteration path..

Okay, thanks.
https://hg.mozilla.org/mozilla-central/rev/16332f72f3c9
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 63
Comment on attachment 8987424 [details]
Bug 1449477: Add test for short duration.

Approval Request Comment
[Feature/Bug causing the regression]: bug 1399830
[User impact if declined]: None (Test only but needed to prevent merge conflicts when bug 1468343 is uplifted)
[Is this code covered by automated tests?]: Yes
[Has the fix been verified in Nightly?]: It has baked on Nightly for 2 days.
[Needs manual test from QE? If yes, steps to reproduce]: No
[List of other uplifts needed for the feature/fix]: No
[Is the change risky?]: No
[Why is the change risky/not risky?]: Test only
[String changes made/needed]: None
Attachment #8987424 - Flags: approval-mozilla-beta?
Comment on attachment 8987424 [details]
Bug 1449477: Add test for short duration.

New tests for a new feature, let's uplift for 62 since we're still in early beta.
Attachment #8987424 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.