Closed Bug 1449478 Opened 2 years ago Closed 2 years ago

Page scrollbar jumps to the wrong position when dragged with WebRender enabled

Categories

(Core :: Graphics: WebRender, defect)

Unspecified
All
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla61
Tracking Status
firefox-esr52 --- unaffected
firefox59 --- unaffected
firefox60 --- unaffected
firefox61 --- fixed

People

(Reporter: cpeterson, Assigned: kats)

References

Details

(Keywords: regression)

Attachments

(2 files)

STR:
1. Enable gfx.webrender.all.
2. Open any web page.
3. Click and drag the spreadsheet's scrollbar.

EXPECTED RESULT:
The scrollbar position should smoothly follow the mouse pointer.

ACTUAL RESULT:
The scrollbar and document position will jump down below the mouse pointer position.

This is a regression from bug 1423370.
Kats, this is a pretty bad WebRender regression from WebRenderLayerScrollData bug 1423370.

I can reproduce this bug in Firefox Nightly 61.0a1 (2018-03-27) on both Windows 10 and macOS.
Flags: needinfo?(bugmail)
OS: Unspecified → All
Assignee: nobody → bugmail
Flags: needinfo?(bugmail)
The second patch is unrelated to this regression, but I'm sticking it here because I'm lazy. I realized the patch from bug 1449419 didn't actually reduce the number of scroll data items because it was still returning true from UpdateScrollData unconditionally, which is what triggers the new scroll data creation. We need it to return false if it's not doing anything.
Comment on attachment 8963045 [details]
Bug 1449478 - Avoid clobbering transforms in the WebRenderScrollData.

https://reviewboard.mozilla.org/r/231886/#review237486
Attachment #8963045 - Flags: review?(jmuizelaar) → review+
Comment on attachment 8963046 [details]
Bug 1449478 - Actually prevent creating new scroll data for simple transform items.

https://reviewboard.mozilla.org/r/231888/#review237490
Attachment #8963046 - Flags: review?(jmuizelaar) → review+
Pushed by kgupta@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/81c55aba2a08
Avoid clobbering transforms in the WebRenderScrollData. r=jrmuizel
https://hg.mozilla.org/integration/autoland/rev/57fe2d9ec554
Actually prevent creating new scroll data for simple transform items. r=jrmuizel
https://hg.mozilla.org/mozilla-central/rev/81c55aba2a08
https://hg.mozilla.org/mozilla-central/rev/57fe2d9ec554
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla61
See Also: → 1450871
Depends on: 1462961
You need to log in before you can comment on or make changes to this bug.