"Empty Trash on Exit" doesn't work

RESOLVED WORKSFORME

Status

SeaMonkey
MailNews: Message Display
RESOLVED WORKSFORME
16 years ago
13 years ago

People

(Reporter: Jann Romer, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.0.0+) Gecko/20020514
BuildID:    2002051408

Option "Empty Trash on Exit" is checkmarked on all accounts but trash folder
doesn't empty when exiting Mozilla.

Reproducible: Always
Steps to Reproduce:
1. Check Option "Empty Trash on Exit" in Mail & Newsgroup Account Settings
2. Exit Mozilla
3. Start Mozilla

Actual Results:  Trash folders still full.

Expected Results:  Trash folders should be empty.

Comment 1

16 years ago
WFM - tested in a profile with only one mail account set up
trunk 2002051408, XP
WFM. Win2k/2002051406.

Comment 3

16 years ago
WFM with Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.0rc2) Gecko/20020510

Comment 4

16 years ago
I have the same problem using bid: 2002071117 with cyrus-imapd-2.1.4-2.
But I get always the message "server responded: mailbox doesn't exist".
This happens when I select empty trash for the imap account in the file menu or
when using the "empty trash on exit" setting and exiting the mail reader.
I get an additional "server responded: mailbox doesn't exist" when the config
item "expunge inbox on exit" is also checked.

When I select the trash folder after using the empty trash menu item (which
produces the errror message as described above) I get again the error msg, and
the folder is displayed as empty. If I select an other folder afterwards and
then again the trash, everything works as expected, but the trashcan is still full.

Comment 5

15 years ago
For me it only works on the first email account.
I have four accounts
using: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130

Updated

15 years ago
QA Contact: olgam → laurel
(Reporter)

Comment 6

15 years ago
I consider this bug as resolved. I didn't experience this problem with later
releases anymore.

Comment 7

15 years ago
For me it now works as well. I don't know why it didn't until yesterday.
Probably because there was no uptodate trash.msf file?

Comment 8

15 years ago
Ok, resolving worksforme then due to comment 6 and 7
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.