Closed Bug 1449531 Opened 3 years ago Closed 3 years ago

no audio connection with webRTC on imac

Categories

(Core :: WebRTC, defect)

59 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1398228

People

(Reporter: mozillabz, Unassigned)

Details

Attachments

(1 file)

Attached file about webrtc.txt
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:59.0) Gecko/20100101 Firefox/59.0
Build ID: 20180323154952

Steps to reproduce:

Firefox 59.0.2, imac late 2012, macbook
1. create room on https://appr.tc on imac
2. join same room on macbook

Observations:

- audio never works on the imac when using firefox. when switching to chromium on imac for the same room, audio connection is established
- the same behavior happens for any webRTC service, firefox imac never establishes audio, while things instantly work when switching to chromium
- issue seems to be related to imac since macbook runs same macOS (10.13.3) and Firefox (59.0.2)
- about:webrtc info attached as txt

Not sure how to best debug this, but it has been happening for a long time and is not limited to recent Firefox releases, I only now decided to file a bug and hope this can be fixed / resolved on my end.


Actual results:

no audio connection


Expected results:

audio connection
Hi steve, thanks for filing.

To proceed with this I'd first like to figure out where in the pipe over to the other side that audio breaks.

First, what microphone are you using? Is it a built-in one, a TRRS (3.5mm plug) connected one or a usb connected one?

Second, what does about:support's Media section say? Is your microphone available under inputs there?

Third, does https://mozilla.github.io/webrtc-landing/gum_test.html work for Audio? (unmute and you should hear yourself) If not, what error do you see?

If it does work, we'll have to look closer at what appr.tc is doing.
Flags: needinfo?(mozillabz)
Whiteboard: [needinfo to reporter on 2018/03/29]
Hi Andreas, thanks for taking the time to debug this.

1. mic: internal built-in mic

2. about:support > Input Devices
Internes Mikrofon	AppleHDAEngineInput:1B,0,1,0:1	Apple Inc.	Enabled	None	default: F32LE, support: S16LE S16BE F32LE F32BE	2	default: 44100, support: 32000 - 96000	81 - 4163

3. https://mozilla.github.io/webrtc-landing/gum_test.html
Visit site, click on audio, select and allow internal mic > audio is working fine
Flags: needinfo?(mozillabz)
Since 3 works, it looks like a appr.tc issue. Would be possible to check with them? What if you try other webrtc services like appear.in or talky.io?
Flags: needinfo?(mozillabz)
Whiteboard: [needinfo to reporter on 2018/03/29] → [needinfo to reporter on 2018/04/04]
1. Test appear.in
No connection between two machines in same network. Both machines connect fine to the servicee but each shows the other machine as "Connection list" "Are you connected to the internet?". No audio / video connection at all with that service.

appear.in tested w chromium works just fine. Video and audio connection made on first attempt.

2. Test talky.io 
Firefox: Preview before joining call shows video + audio active. When making noise the mic indicator shows it's receiving sound. When both machines are in a room no audio connection is made.
Chromium: Enter a room and immediately see "Oops! The connection was lost. Retrying..." and that never goes away.


What I gather from those tests:
a) Test 1 seems to confirm the behavior I initially described in my post that with the imac I am still unable to get an audio connection via WebRTC when using Firefox, no matter which services. That indicates the issue is indeed with firefox and not with a specific services. The services tested with all work perfectly fine (audio as well as video) on that machine when using Chromium.
b) talky.io seems to have general issues with chromium as the same error shows on various machines and no connection can be made at all using chromium.
Flags: needinfo?(mozillabz)
Gotcha. It could be something like the webrtc blocking option in uBlock Origin: https://github.com/gorhill/uBlock/issues/3009

Do you have any extensions installed? If so, what if you disable them or try in safe mode?

If not we'll have to look at your network I think. https://test.webrtc.org/ is also useful for testing that everything works.
Flags: needinfo?(mozillabz)
Wow this is highly embarrassing! Sorry for stealing your time. Indeed the WebRTC prevent IP leakage setting in uBlock Origin was enabled. Feel free to close this as user stupidity bug or even delete it from the database as it provides no value.

:/ Sorry again!
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Flags: needinfo?(mozillabz)
Resolution: --- → INVALID
(In reply to steve-_- from comment #6)
> Wow this is highly embarrassing! Sorry for stealing your time. Indeed the
> WebRTC prevent IP leakage setting in uBlock Origin was enabled. Feel free to
> close this as user stupidity bug or even delete it from the database as it
> provides no value.
> 
> :/ Sorry again!

No problem!

But if you insist on feeling bad, feel free to reach out to uBlock on this as their setting is not working as intended. More details in the issue I linked in comment 5. :-)
Resolution: INVALID → WORKSFORME
Oh, this is actually a dupe.
Resolution: WORKSFORME → DUPLICATE
Whiteboard: [needinfo to reporter on 2018/04/04]
Duplicate of bug: 1398228
You need to log in before you can comment on or make changes to this bug.