Unreadable "Hide Bookmarks Sidebar" menu on Dark theme

VERIFIED FIXED in Firefox 61

Status

()

defect
P3
normal
VERIFIED FIXED
a year ago
11 months ago

People

(Reporter: euthanasia_waltz, Assigned: dao)

Tracking

61 Branch
Firefox 62
x86_64
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox61 verified, firefox62 verified)

Details

Attachments

(2 attachments)

(Reporter)

Description

a year ago
Posted image screenshot
(app menu->)Library->Bookmarks->Bookmarking Tools->Hide Bookmarks Sidebar
filled with dark color.

Hover makes it normal.(color is white on hover)
"View Bookmarks Sidebar" is not affected.(no problem)
Linux only.
(Assignee)

Updated

a year ago
Blocks: 1408121
Priority: -- → P3
Dão, do you know if this ruleset can be removed or should it be overriden in panelUI.inc.css ?
Flags: needinfo?(dao+bmo)
(Assignee)

Comment 3

a year ago
(In reply to Tim Nguyen :ntim from comment #2)
> Dão, do you know if this ruleset can be removed or should it be overriden in
> panelUI.inc.css ?

Afaik Gtk themes tend to render -moz-appearance: toolbarbutton; opaque in the checked state (as well as hover, active and open), so this would still be needed.
Flags: needinfo?(dao+bmo)

Updated

11 months ago
See Also: → 1463720
(Assignee)

Updated

11 months ago
See Also: 1463720
Duplicate of this bug: 1463720
(Assignee)

Updated

11 months ago
Assignee: nobody → dao+bmo
Status: NEW → ASSIGNED

Comment 6

11 months ago
mozreview-review
Comment on attachment 8980545 [details]
Bug 1449547 - Make subviewbuttons override the toolkit default color for checked toolbarbuttons.

https://reviewboard.mozilla.org/r/246704/#review253002
Attachment #8980545 - Flags: review?(jaws) → review+

Comment 7

11 months ago
Thanks for picking this up :)

Comment 8

11 months ago
Pushed by ntim.bugs@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/cb31cfa8b634
Make subviewbuttons override the toolkit default color for checked toolbarbuttons. r=jaws

Comment 9

11 months ago
Comment on attachment 8980545 [details]
Bug 1449547 - Make subviewbuttons override the toolkit default color for checked toolbarbuttons.

Approval Request Comment
[Feature/Bug causing the regression]: bug 1408121
[User impact if declined]: attachment 8963091 [details] and attachment 8980362 [details] 
[Is this code covered by automated tests?]: no
[Has the fix been verified in Nightly?]: not yet
[Needs manual test from QE? If yes, steps to reproduce]: see comment 0 and bug 1463720
[List of other uplifts needed for the feature/fix]: n/a
[Is the change risky?]: no
[Why is the change risky/not risky?]: css only
[String changes made/needed]:
Attachment #8980545 - Flags: approval-mozilla-beta?

Comment 10

11 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/cb31cfa8b634
Status: ASSIGNED → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 62
(Assignee)

Updated

11 months ago
Blocks: 1464581
Flags: qe-verify+
Comment on attachment 8980545 [details]
Bug 1449547 - Make subviewbuttons override the toolkit default color for checked toolbarbuttons.

More dark theme improvements. Approved for 61.0b9.
Attachment #8980545 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
I could observe this issue on Firefox 61.0a1 (2018-03-28) under Ubuntu 16.04 x64.
The bug is fixed on Firefox 62.0a1 (2018-05-28) and Firefox 61.0b9 ( 20180528091514) under Ubuntu 16.04 x64, Ubuntu 14.04 x32, Windows 10 x64 and macOS 10.13.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.