Closed Bug 1449583 Opened 4 years ago Closed 4 years ago

Themes installed before sync are removed but still appear as activated in about:addons

Categories

(Toolkit :: Add-ons Manager, defect, P5)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1430276
Tracking Status
firefox59 --- wontfix
firefox60 --- fix-optional
firefox61 --- affected

People

(Reporter: oana.botisan, Unassigned)

Details

[Affected versions]:
- DevEdition 60.0b7 
- Nightly 61.0a1
- Firefox 59.0.2

[Affected platforms]:
- Windows 7 x32
- Ubuntu 16.04 x64
- macOS 10.13 / Mac OS 10.11

[Steps to reproduce]:
1. Go to about:addons (Get Add-ons)
2. Activate one of the featured themes from the page.
3. In another tab sign in to Sync
4. Go back to about:addons (Themes) and observe behaviour.

[Expected result]:
I am not sure what is the expected result here. It's either:
- The old theme is kept and the new theme appears in about:addons (Themes)
or:
- The new theme is kept and the old theme can be found in about:addons (Themes)

[Actual result]:
- the theme appears in about:addons (Themes) as enabled and you can't disable it.
- visually the theme changes to the one you had before on your Mozilla profile and if the page is refreshed, the theme from step 2 disappears from the list.
- in about:addons (Get Add-ons) the theme selected in step 2 remains activated and if you try to deactivate it an error is displayed: "An unexpected error occurred during uninstallation." When the page is refreshed, the issue disappears.

[Regression range]:
- I am not sure if this is a regression, but if I find one, I will put it in a comment.

[Additional notes]:
- When the sync profile doesn't have a theme selected, the new theme is listed in the about:addons (Themes) and can't be disabled. And in about:addons (Get Add-ons) the theme looks like it's activated and if you try to deactivate it an error is displayed: "An unexpected error occurred during uninstallation." When the page is refreshed, the issue disappears.
I don't think this is a regression. I could reproduce this issue even on Nightly 31.0a1 (2014-04-26).
Component: Theme → Add-ons Manager
Product: Firefox → Toolkit
Priority: -- → P5
Realizing this isn't a straight dupe, but if this is about LWT, it's moot with the migration to static themes.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1430276
You need to log in before you can comment on or make changes to this bug.