Closed Bug 1449585 Opened 4 years ago Closed 4 years ago

The install button for “Search and Wider Mail by Yahoo” add-on inside yahoo mail page is not functional

Categories

(Toolkit :: Add-ons Manager, defect)

defect
Not set
minor

Tracking

()

RESOLVED INVALID

People

(Reporter: Anca, Unassigned)

Details

[Affected versions]: 
- 59.0.2 (20180323154952)
- 60.0b7 dev ed (20180326164103)
- 61.0a1 (2018-03-28)

[Affected platforms]:
- Mac OS 10.10
- macOS 10.13
- Ubuntu 16.04 x64
- Windows 10 x64

[Steps to reproduce]:
1. Go to https://mail.yahoo.com/ and log in
2. Click on the Hide advertisement  “ > ” button ( mid-right side)
3. Click on the Install button ( https://goo.gl/yN3AhM )

[Expected result]:
- “Search and Wider Mail by Yahoo” extensions dialog prompt is displayed.

[Actual result]:
- Nothing happens.

[Regression range]:
- This is not a regression, I can see the same behavior since this add-on appeared, Firefox 53.0a1 (20161121030224).

[Additional notes]:
- The error displayed inside the browser console is the following: 
ReferenceError: chrome is not defined: 
view-source:https://s.yimg.com/nq/nr/js/mail_app_lazy_group1_jUTalou8s6GBrO5NtcqK8hLpTloj7mHlTqzgJ0H8Xjw.js 7:138808
Moving to WebExtensions: General, although this might be a site compatibility issue.  I can't easily find documentation below https://developer.mozilla.org/en-US/Add-ons/Distribution that explains how sites would trigger an option to directly install from the site.  I'm assuming the "chrome is not defined" means Google Chrome exposes a "chrome" property on a global object somewhere.
Component: DOM: Events → WebExtensions: General
Product: Core → Toolkit
This sounds like that web page is using Chrome's inline extension installation flow:
https://developer.chrome.com/webstore/inline_installation

That's not something that we support in Firefox.
Status: NEW → RESOLVED
Closed: 4 years ago
Component: WebExtensions: General → Add-ons Manager
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.