Status

()

enhancement
RESOLVED DUPLICATE of bug 1445465
a year ago
a year ago

People

(Reporter: RyanVM, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

()

Reporter

Description

a year ago
ICU 61.1 was released this week. Not sure what the urgency is for updating on our end, but probably good to have a bug on file for it anyway.

Common Changes
* CLDR 33:
  - Two additional locales (Odia, Assamese) were brought up to Modern coverage level.
  - 4 new transforms: fa-fa_FONIPA, ha-ha_NE, nv-nv_FONIPA, vec-vec_FONIPA.
  - New currency code MRU for Mauritania.
  - Arabic native vs. ASCII digits: It is now possible to change a single data value (locales/ar.txt NumberElements/default → "latn", rebuild ICU data) in order to switch Arabic-language (but not Arabic-country-variant) number formatting from native digits (٠١٢٣٤٥٦٧٨٩) to ASCII digits (0123456789) which are more widely understood. (ICU #13567, CLDR #10825)
  - Data additions & bug fixes.
* Many small API additions, improvements, and bug fixes.

ICU4C Specific Changes
* Added Google double-conversion library for formatting doubles (#11318).  This is the library used in V8 and a number of other projects for converting doubles to decimals.  To avoid name collisions, the library is linked internally under the ICU namespace as icu::double_conversion.  Our copy of double_conversion is not intended for public usage.
* Re-wrote U8_NEXT macros to eliminate all library function calls. (#13467)

ICU4J Specific Changes
* Under-the-hood overhaul of number and currency parsing. See the design doc for a summary of changes; behavior is mostly compatible with previous versions, but there are some known differences. Please report issues on #13513.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1445465
You need to log in before you can comment on or make changes to this bug.