Closed Bug 1449638 Opened 3 years ago Closed 3 years ago

[Static Analysis] Add some tests for `./mach static-analysis check`

Categories

(Firefox Build System :: Source Code Analysis, enhancement)

3 Branch
enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1432410

People

(Reporter: janx, Assigned: andi)

References

Details

Attachments

(1 file)

No description provided.
Assignee: nobody → bpostelnicu
This is a quick hack I tried today, but I didn't get very far. I'm uploading the patch here just in case it can be useful to you (for inspiration).

Ahal suggested creating a new `python.ini` file, with another test subsuite for code analysis, so I tried that. But then I didn't understand `pytest` enough to actually write any tests.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1432410
Version: Version 3 → 3 Branch
You need to log in before you can comment on or make changes to this bug.