Closed Bug 1449640 Opened 2 years ago Closed 2 years ago

Don't compute a scale for 3d transformed content

Categories

(Core :: Graphics: WebRender, enhancement)

enhancement
Not set

Tracking

()

RESOLVED FIXED
mozilla61
Tracking Status
firefox61 --- fixed

People

(Reporter: jrmuizel, Assigned: jrmuizel)

References

Details

Attachments

(1 file)

No description provided.
Comment on attachment 8963300 [details]
Bug 1449640. Don't compute a scale for 3d transformed content.

https://reviewboard.mozilla.org/r/232204/#review237676

ChooseScaleAndSetTransform, my old nemesis. I never did understand that code, and I don't really understand this. But if it passes tests, r+

::: gfx/layers/wr/StackingContextHelper.cpp:18
(Diff revision 1)
>  namespace layers {
>  
>  StackingContextHelper::StackingContextHelper()
>    : mBuilder(nullptr)
>    , mScale(1.0f, 1.0f)
>    , mAffectsClipPositioning(false)

This constructor should initialize mIsPreserve3D also
Attachment #8963300 - Flags: review?(bugmail) → review+
Pushed by jmuizelaar@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4d30ebcdc5ac
Don't compute a scale for 3d transformed content. r=kats
https://hg.mozilla.org/mozilla-central/rev/4d30ebcdc5ac
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla61
Duplicate of this bug: 1432559
Assignee: nobody → jmuizelaar
You need to log in before you can comment on or make changes to this bug.