Ansible documentation misrendering on nightly

RESOLVED DUPLICATE of bug 1446442

Status

()

defect
RESOLVED DUPLICATE of bug 1446442
a year ago
a year ago

People

(Reporter: Alex_Gaynor, Unassigned)

Tracking

(Blocks 1 bug)

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox61 affected)

Details

This bisects to this range:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=4ad2150e73c0b19f1f6264a4b9ad6927986d43ce&tochange=37e0bd919af057d44c5c1410458c0f00a3653c11

--> Regression from Bug 1035091 (which removed support for @-moz-document)

That Ansible page has this chunk in their "theme.css" file:

> @-moz-document url-prefix() {
>     .return-value-column td {
>         height: 100%
>     }
> }
https://docs.ansible.com/ansible/latest/_static/css/theme.css

...and if I use devtools to remove that chunk, in a pre-regression Firefox build, then I can trigger the issue there too.
Blocks: 1035091
Good news - this is the sort of markup that's intended to be fixed by bug 1446470.

Though it looks like that bug's fix is behind a pref, layout.css.moz-document.url-prefix-hack.enabled, which is off by default. If I enable that pref, this site works.  Emilio, do you know if we have a bug filed on enabling that yet?
Depends on: 1446470
Flags: needinfo?(emilio)
Reporter

Comment 3

a year ago
I'm not familiar with our CSS system at all; should I file a bug upstream with Ansible, or is this expected to work?
Probably not worth an upstream bug at this point, no.  (Though depending on how much diagnosis you want to do, maybe it'd end up being worth it.)

Roughly, what's happening here is that Ansible has got some HTML table content that renders differently in Firefox for some reason, and they used "@-moz-document url-prefix()" as a hacky "if (firefox) {...} " check to add some Firefox-specific hackaround CSS to make it render how they want.  And we've briefly disabled that hackaround technique, but we're restoring it soon.

So: under the covers, there does seem to be an HTML Table interop issue of some sort here (which they're successfully working around with the -moz-document hackaround).  It'd require a bit of digging / testcase minimization to figure out what that interop issue is, and who's correct.  (And HTML tables are notoriously underspecified & have not-great-interop, too, so this isn't 100% surprising and there may already be bugs filed on whatever the underlying issue ends up being.)

In any case, though, I'm pretty sure we're restoring the @-moz-document url-prefix() hackaround, so this Ansible doc should start working again soon [via that hackaround being recognized again]. (pending emilio's thoughts on when we're enabling that pref to restore it.)
(In reply to Daniel Holbert [:dholbert] from comment #2)
> Good news - this is the sort of markup that's intended to be fixed by bug
> 1446470.
> 
> Though it looks like that bug's fix is behind a pref,
> layout.css.moz-document.url-prefix-hack.enabled, which is off by default. If
> I enable that pref, this site works.  Emilio, do you know if we have a bug
> filed on enabling that yet?

That pref is intentionally turned to false for Early beta / nightly so we can know when if ever we can turn it back on.
Flags: needinfo?(emilio)
That being said, this looks like exactly the same issue as bug 1446442.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1446442
You need to log in before you can comment on or make changes to this bug.