Closed Bug 1449754 Opened 4 years ago Closed 7 months ago

Intermittent devtools/client/inspector/test/browser_inspector_highlighter-rulers_03.js | Dimension text was created successfully - Got A, expected B

Categories

(DevTools :: Inspector, defect, P5)

defect

Tracking

(firefox88 fixed)

RESOLVED FIXED
Tracking Status
firefox88 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: jdescottes)

References

(Blocks 1 open bug)

Details

(Keywords: intermittent-failure, Whiteboard: [stockwell disabled][stockwell needswork:owner])

Attachments

(2 files)

Filed by: rgurzau [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=170890267&repo=mozilla-inbound

https://queue.taskcluster.net/v1/task/ASFLpLK2To2rXXK2nFynJQ/runs/0/artifacts/public/logs/live_backing.log

20:31:30     INFO -  434 INFO TEST-START | devtools/client/inspector/test/browser_inspector_highlighter-rulers_03.js
20:31:30     INFO -  TEST-INFO | started process screenshot
20:31:30     INFO -  TEST-INFO | screenshot: exit 0
20:31:30     INFO -  Buffered messages logged at 20:31:30
20:31:30     INFO -  435 INFO Entering test bound
20:31:30     INFO -  436 INFO Adding a new tab with URL: data:text/html;charset=utf-8,<div style='position:absolute;left: 0; top: 0; width: 20px; height: 50px'></div>
20:31:30     INFO -  437 INFO Tab added and finished loading
20:31:30     INFO -  438 INFO Opening the inspector
20:31:30     INFO -  439 INFO Opening the toolbox
20:31:30     INFO -  440 INFO Console message: [JavaScript Warning: "Unknown property ‘user-select’.  Declaration dropped." {file: "resource://devtools/client/shared/components/reps/reps.css" line: 290}]
20:31:30     INFO -  441 INFO Console message: [JavaScript Warning: "Unknown property ‘user-select’.  Declaration dropped." {file: "resource://devtools/client/shared/components/reps/reps.css" line: 290}]
20:31:30     INFO -  442 INFO Toolbox opened and focused
20:31:30     INFO -  443 INFO Checking that the viewport infobar is displayed
20:31:30     INFO -  444 INFO TEST-PASS | devtools/client/inspector/test/browser_inspector_highlighter-rulers_03.js | viewport infobar is visible after show -
20:31:30     INFO -  445 INFO Checking the rulers dimension tooltip have the proper text
20:31:30     INFO -  446 INFO TEST-PASS | devtools/client/inspector/test/browser_inspector_highlighter-rulers_03.js | Dimension text was created successfully -
20:31:30     INFO -  447 INFO Docking the toolbox to the side of the browser to change the window size
20:31:30     INFO -  448 INFO Checking the rulers dimension tooltip have the proper text
20:31:30     INFO -  Buffered messages finished
20:31:30    ERROR -  449 INFO TEST-UNEXPECTED-FAIL | devtools/client/inspector/test/browser_inspector_highlighter-rulers_03.js | Dimension text was created successfully - Got 699px × 780px, expected 949px × 780px
In the last 7 days there are 50 failures.
They occur on Windows10-64 and Windows7-32. The affected builds type are pgo and opt.
Recent failure log:  https://treeherder.mozilla.org/logviewer.html#?job_id=179298423&repo=mozilla-inbound&lineNumber=3446
and a relevant part of it: 
05:55:03     INFO -  541 INFO Docking the toolbox to the side of the browser to change the window size
05:55:03     INFO -  542 INFO Checking the rulers dimension tooltip have the proper text
05:55:03     INFO -  Buffered messages finished
05:55:03    ERROR -  543 INFO TEST-UNEXPECTED-FAIL | devtools/client/inspector/test/browser_inspector_highlighter-rulers_03.js | Dimension text was created successfully - Got 699px × 780px, expected 949px × 780px
05:55:03     INFO -  Stack trace:
05:55:03     INFO -  chrome://mochikit/content/browser-test.js:test_is:1285
05:55:03     INFO -  chrome://mochitests/content/browser/devtools/client/inspector/test/browser_inspector_highlighter-rulers_03.js:hasRightLabelsContent:55
05:55:03     INFO -  chrome://mochitests/content/browser/devtools/client/inspector/test/browser_inspector_highlighter-rulers_03.js:null:26
05:55:03     INFO -  chrome://mochikit/content/browser-test.js:Tester_execTest/<:1083
05:55:03     INFO -  chrome://mochikit/content/browser-test.js:Tester_execTest:1074
05:55:03     INFO -  chrome://mochikit/content/browser-test.js:nextTest/<:976
05:55:03     INFO -  chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<:795
05:55:03     INFO -  544 INFO Leaving test bound
05:55:03     INFO -  545 INFO Removing tab.
05:55:03     INFO -  546 INFO Waiting for event: 'TabClose' on [object XULElement].
05:55:03     INFO -  547 INFO Got event: 'TabClose' on [object XULElement].
05:55:03     INFO -  548 INFO Tab removed and finished closing
:gl, can you have a look at this?
Flags: needinfo?(gl)
Whiteboard: [stockwell needswork]
Duplicate of this bug: 1462943
Seems like a test timing issue to me. The toolbox is switched to the side host and then the test checks the rulers again.
For some reason, the width is right (780px), but the height is 699px while the window height really is 949px.
Maybe we measure too early, right when the side host has been created but the bottom host has not yet been destroyed.
Comment on attachment 8980848 [details] [diff] [review]
Skipped browser_inspector_highlighter-rulers_03.js on windows and !debug for frequent failures

Review of attachment 8980848 [details] [diff] [review]:
-----------------------------------------------------------------

excellent
Attachment #8980848 - Flags: review?(jmaher) → review+
Flags: needinfo?(jmaher)
Whiteboard: [stockwell disable-recommended] → [stockwell disabled]
Pushed by dluca@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/d4393b6057dc
disable browser_inspector_highlighter-rulers_03.js on Windows !debug for frequent failures. r=jmaher
Keywords: checkin-needed
Product: Firefox → DevTools
Flags: needinfo?(gl)

This test fails everytime with slightly different error messages (because the message depends on the screen size).
So I'm making bug's title more generic, and will close all other bugs as duplicates.

Summary: Intermittent devtools/client/inspector/test/browser_inspector_highlighter-rulers_03.js | Dimension text was created successfully - Got 699px × 780px, expected 949px × 780px → Intermittent devtools/client/inspector/test/browser_inspector_highlighter-rulers_03.js | Dimension text was created successfully - Got A, expected B
Duplicate of this bug: 1578204
Duplicate of this bug: 1579561
Duplicate of this bug: 1586286
Duplicate of this bug: 1595071
Duplicate of this bug: 1599234
Duplicate of this bug: 1605276

There are 23 total failures in the last 7 days, affected platforms are linux1804-64 opt, linux1804-64-shippable opt and macosx1014-64-shippable
opt: https://treeherder.mozilla.org/intermittent-failures.html#/bugdetails?startday=2020-05-16&endday=2020-05-23&tree=trunk&bug=1449754

Recent log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=303424336&repo=autoland&lineNumber=7810

Gabriel, are there any updated on this?

Flags: needinfo?(gl)
Whiteboard: [stockwell disabled] → [stockwell disabled][stockwell needswork:owner]

In the last 7 days there have been 20 occurrences on linux 64 and OS X 64 opt.

Recent failure: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=306186259&repo=autoland&lineNumber=4247

[task 2020-06-13T00:37:22.544Z] 00:37:22     INFO - TEST-START | devtools/client/inspector/test/browser_inspector_highlighter-rulers_03.js
[task 2020-06-13T00:37:22.785Z] 00:37:22     INFO - GECKO(2924) | console.error: "Store does not have a valid reducer. Make sure the argument passed to combineReducers is an object whose values are reducers."
[task 2020-06-13T00:37:22.970Z] 00:37:22     INFO - GECKO(2924) | console.log: "[DISPATCH] action type:" "UPDATE_GRIDS"
[task 2020-06-13T00:37:22.999Z] 00:37:22     INFO - GECKO(2924) | console.log: "[DISPATCH] action type:" "UPDATE_GRIDS"
[task 2020-06-13T00:37:23.001Z] 00:37:23     INFO - GECKO(2924) | console.log: "[DISPATCH] action type:" "CLEAR_FLEXBOX"
[task 2020-06-13T00:37:23.017Z] 00:37:23     INFO - GECKO(2924) | console.log: "[DISPATCH] action type:" "CLEAR_FLEXBOX"
[task 2020-06-13T00:37:23.018Z] 00:37:23     INFO - GECKO(2924) | console.log: "[DISPATCH] action type:" "UPDATE_OFFSET_PARENT"
[task 2020-06-13T00:37:23.019Z] 00:37:23     INFO - GECKO(2924) | console.log: "[DISPATCH] action type:" "UPDATE_LAYOUT"
[task 2020-06-13T00:37:23.247Z] 00:37:23     INFO - GECKO(2924) | console.log: "[DISPATCH] action type:" "CLEAR_FLEXBOX"
[task 2020-06-13T00:37:23.251Z] 00:37:23     INFO - TEST-INFO | started process screentopng
[task 2020-06-13T00:37:23.522Z] 00:37:23     INFO - TEST-INFO | screentopng: exit 0
[task 2020-06-13T00:37:23.523Z] 00:37:23     INFO - Buffered messages logged at 00:37:22
[task 2020-06-13T00:37:23.524Z] 00:37:23     INFO - Entering test bound 
[task 2020-06-13T00:37:23.526Z] 00:37:23     INFO - Adding a new tab with URL: data:text/html;charset=utf-8,<div style='position:absolute;left: 0; top: 0; width: 20px; height: 50px'></div>
[task 2020-06-13T00:37:23.526Z] 00:37:23     INFO - Tab added and finished loading
[task 2020-06-13T00:37:23.527Z] 00:37:23     INFO - Opening the inspector
[task 2020-06-13T00:37:23.528Z] 00:37:23     INFO - Opening the toolbox
[task 2020-06-13T00:37:23.529Z] 00:37:23     INFO - Buffered messages logged at 00:37:23
[task 2020-06-13T00:37:23.529Z] 00:37:23     INFO - Toolbox opened and focused
[task 2020-06-13T00:37:23.530Z] 00:37:23     INFO - Checking that the viewport infobar is displayed
[task 2020-06-13T00:37:23.531Z] 00:37:23     INFO - TEST-PASS | devtools/client/inspector/test/browser_inspector_highlighter-rulers_03.js | viewport infobar is visible after show - 
[task 2020-06-13T00:37:23.531Z] 00:37:23     INFO - Checking the rulers dimension tooltip have the proper text
[task 2020-06-13T00:37:23.531Z] 00:37:23     INFO - TEST-PASS | devtools/client/inspector/test/browser_inspector_highlighter-rulers_03.js | Dimension text was created successfully - 
[task 2020-06-13T00:37:23.531Z] 00:37:23     INFO - Docking the toolbox to the side of the browser to change the window size
[task 2020-06-13T00:37:23.531Z] 00:37:23     INFO - Checking the rulers dimension tooltip have the proper text
[task 2020-06-13T00:37:23.532Z] 00:37:23     INFO - Buffered messages finished
[task 2020-06-13T00:37:23.532Z] 00:37:23     INFO - TEST-UNEXPECTED-FAIL | devtools/client/inspector/test/browser_inspector_highlighter-rulers_03.js | Dimension text was created successfully - Got 780px × 716px, expected 780px × 966px
[task 2020-06-13T00:37:23.532Z] 00:37:23     INFO - Stack trace:
[task 2020-06-13T00:37:23.532Z] 00:37:23     INFO - chrome://mochikit/content/browser-test.js:test_is:1327
[task 2020-06-13T00:37:23.532Z] 00:37:23     INFO - chrome://mochitests/content/browser/devtools/client/inspector/test/browser_inspector_highlighter-rulers_03.js:hasRightLabelsContent:65
[task 2020-06-13T00:37:23.532Z] 00:37:23     INFO - chrome://mochitests/content/browser/devtools/client/inspector/test/browser_inspector_highlighter-rulers_03.js:null:27
[task 2020-06-13T00:37:23.532Z] 00:37:23     INFO - chrome://mochikit/content/browser-test.js:Tester_execTest/<:1064
[task 2020-06-13T00:37:23.532Z] 00:37:23     INFO - chrome://mochikit/content/browser-test.js:Tester_execTest:1104
[task 2020-06-13T00:37:23.532Z] 00:37:23     INFO - chrome://mochikit/content/browser-test.js:nextTest/<:927
[task 2020-06-13T00:37:23.532Z] 00:37:23     INFO - chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<:918
[task 2020-06-13T00:37:23.532Z] 00:37:23     INFO - Checking that the viewport infobar is hidden after disabling
[task 2020-06-13T00:37:23.533Z] 00:37:23     INFO - GECKO(2924) | console.log: "[DISPATCH] action type:" "UPDATE_OFFSET_PARENT"
[task 2020-06-13T00:37:23.533Z] 00:37:23     INFO - GECKO(2924) | console.log: "[DISPATCH] action type:" "UPDATE_LAYOUT"
[task 2020-06-13T00:37:23.534Z] 00:37:23     INFO - TEST-PASS | devtools/client/inspector/test/browser_inspector_highlighter-rulers_03.js | viewport infobar is hidden after hide - 
[task 2020-06-13T00:37:23.534Z] 00:37:23     INFO - Leaving test bound 
Flags: needinfo?(gl)

Julian, could you please redirect this to someone who could take a look?

Flags: needinfo?(jdescottes)

This is the only highlighter-ruler test which modifies the size of the window via toolbox dock mode change.
There are a couple of issues:
We assume that the highlighter will be updated when we ask for its new content but we are not waiting on any event.
We also assume that the window size can be measured immediately after changing the docking mode.

Addressing the first issue by using asyncWaitUntil already reduces the failure rate significantly.
To address the second issue I am just adding a small delay before measuring the window dimension.
We could probably get a more in-depths fix and try to wait for rendering/paint/etc... I don't think it's worth the effort in the scope of this intermittent

Flags: needinfo?(jdescottes)
Pushed by jdescottes@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e6af5e382d20
[devtools] Wait for ruler text to be updated in browser_inspector_highlighter-rulers_03.js r=ladybenko

No new failure since the fix landed

Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Assignee: nobody → ebalazs
Assignee: ebalazs → jdescottes
See Also: → 1731679
You need to log in before you can comment on or make changes to this bug.