Closed Bug 1449901 Opened 3 years ago Closed 3 years ago

WebGL framerate is low on high resolution screens

Categories

(Core :: Canvas: WebGL, defect, P5)

61 Branch
defect

Tracking

()

RESOLVED DUPLICATE of bug 1010527

People

(Reporter: mail, Unassigned)

Details

(Keywords: perf, Whiteboard: [gfx-noted])

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:61.0) Gecko/20100101 Firefox/61.0
Build ID: 20180328100134

Steps to reproduce:

Visit a trivial WebGL example such as https://threejs.org/docs/scenes/geometry-browser.html#BoxGeometry on a high resolution browser window (e.g. 4K displays, such as 3840x2160, or using a normal 1600x1200 display and dragging the window so that it is larger than the screen size).

Enable "layers.acceleration.draw-fps" in about:config to see FPS.


Actual results:

FPS drops very low (below 30) on high resolution, and the trivial cube's motion starts jagging.

I tested this on Ubuntu 16.04 (nvidia) and a Macbook with OSX, with FF Nightly 61 and 59 release.


Expected results:

FPS stays high. I compared to Chromium 65, where the FPS stays around 60.
I should also say: On low resolutions (like 1600x1200), I get clean 60 FPS for this trivial cube geometry on all platforms.

It is high resolution browser window sizes (so, "normal" window sizes on 4K displays) that Firefox WebGL has problems with.
Component: Untriaged → Canvas: WebGL
Product: Firefox → Core
Currently on Linux there is a readback to system memory of the WebGL canvas before it is composited. This readback exists because we have to send the canvas layer from the content process to the compositor process over shared memory. This is unfortunately a known drag on Linux WebGL performance that we haven't gotten around to solving yet.
OS: Unspecified → Linux
Priority: -- → P5
Hardware: Unspecified → x86_64
Whiteboard: [gfx-noted]
@lsalzman: This issue is NOT a Linux-specific issue.

As I wrote into the issue description, the same problem happens on OSX (and it may well also happen on Windows but I haven't had a chance to test that yet).

Would you mind adjusting the issue flags accordingly? Thanks!
Flags: needinfo?(lsalzman)
Flags: needinfo?(lsalzman)
Keywords: perf
OS: Linux → All
Hardware: x86_64 → All
yes, it has nothing to do with Linux as it works well on Linux google chrome.
It firefox slow in all webgl not just google maps. Google Chrome webgl runs 60fps on 4k resolutions.

The firefox webgl I noticed always been slow. 

can compare webglsamples.org
for example the Aquarium 5000 fish 
firefox 30fps 4k
chrome 60fps 4k
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: slow-linux-webgl
You need to log in before you can comment on or make changes to this bug.