Closed Bug 1449965 Opened 2 years ago Closed 2 years ago

There's no way to see the progress of the build.

Categories

(Firefox Build System :: General, defect)

3 Branch
defect
Not set

Tracking

(firefox61 fixed)

RESOLVED FIXED
mozilla61
Tracking Status
firefox61 --- fixed

People

(Reporter: emilio, Assigned: chmanchester)

References

Details

Attachments

(1 file)

Since bug 1429875, I believe (haven't double-checked), most of the libxul build is silent (only cargo output shows up).

Before that a bunch foo.desc lines appeared, which confirmed that there was something going on.

It's nice to be able to know that stuff is going on. For example today I lost 30 minutes because icecream had hanged, yet I thought the build was still running.
+1 to that. Just got hit with this change and its really hard to understand how's the progress going and any hangs will stay hidden.
We're no longer generating .desc files since bug 1429875, so that would explain it. At some point we stopped printing output for individual file compilations as well. We should find a middle ground here.
Blocks: 1429875
Would it be too noisy to print every directory we enter (maybe just for 'libs')?  That would provide a rough approximation of what the previous .desc printing did.
And since we're at it, it's always been a major productivity hurdle for me to have to guess how far in the compilation am I. I know it's hard to do ETA, but maybe we could at least show (x/y) kind of `(124/2782)` info to give you an insight into how far are we.
Assignee: nobody → cmanchester
(In reply to Zibi Braniecki [:gandalf][:zibi] from comment #4)
> And since we're at it, it's always been a major productivity hurdle for me
> to have to guess how far in the compilation am I. I know it's hard to do
> ETA, but maybe we could at least show (x/y) kind of `(124/2782)` info to
> give you an insight into how far are we.

We talked about this at the build team work week and agreed that the current state of affairs is a bit too silent (hence chmanchester's patch), but that we're not going to do work to provide a progress meter of any kind because tup has this functionality, and we're actively working towards making the tup backend usable.
Attachment #8969175 - Flags: review?(core-build-config-reviews) → review?(ted)
Comment on attachment 8969175 [details]
Bug 1449965 - Output directories during the build as we compile object files.

https://reviewboard.mozilla.org/r/237912/#review243734
Attachment #8969175 - Flags: review?(ted) → review+
Pushed by cmanchester@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9c246c15f12a
Output directories during the build as we compile object files. r=ted
https://hg.mozilla.org/mozilla-central/rev/9c246c15f12a
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla61
Duplicate of this bug: 1458889
Version: Version 3 → 3 Branch
You need to log in before you can comment on or make changes to this bug.