Closed Bug 1450019 Opened 2 years ago Closed 9 months ago

Snaps aren't uploaded to archive.mozilla.org anymore

Categories

(Release Engineering :: Release Automation: Snap, defect)

defect
Not set

Tracking

(firefox67 fixed, firefox68 fixed)

VERIFIED FIXED
Tracking Status
firefox67 --- fixed
firefox68 --- fixed

People

(Reporter: jlorenzo, Assigned: jlorenzo)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

Last found: https://archive.mozilla.org/pub/firefox/candidates/58.0b16-candidates/build1/snap/
First missing: https://archive.mozilla.org/pub/firefox/candidates/59.0b3-candidates/build2/

It seems we forgot to let the new beetmover know about snaps, during tc-migration
Component: Release Automation: Other → Release Automation: Snap
There are any updates related to this issue? I'm asking because I what to download some older snap release builds.
Depends on: 1529257

Upload snap to archive.m.o

Assignee: nobody → jlorenzo
Pushed by jlorenzo@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2609a881de00
Upload snap to archive.m.o r=mtabara
Pushed by jlorenzo@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/99bd081df222
Upload snap to archive.m.o r=mtabara

Thank you very much for backing my patch. I apologize for the breakage. It was caused by the last-minute rebase. This is now fixed.

Flags: needinfo?(jlorenzo)
Status: NEW → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED

Snaps have been automatically uploaded since Firefox 67.0b6: https://archive.mozilla.org/pub/firefox/candidates/67.0b6-candidates/build1/snap/

I'll file another bug like bug 1529257 to upload the ones that have been missing, since then. I'll do it once 67.0 reaches release. This way the bug won't miss any 66.0.x releases.

Status: RESOLVED → VERIFIED
Blocks: 1542185
Type: enhancement → defect
You need to log in before you can comment on or make changes to this bug.