input type="submit" text label position when using styles

RESOLVED DUPLICATE of bug 165329

Status

()

Core
Layout: Form Controls
RESOLVED DUPLICATE of bug 165329
16 years ago
15 years ago

People

(Reporter: Andrew Paul Cottrell, Assigned: rods (gone))

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
I created a form with an input element (type="submit"), then I styled the
control using CSS. I set a small font (7pt) and set the height to 2em. I found
that the text label, "GO", was aligned with the bottom of the control. By
varying the height I found that there is padding within the control around the
text. I expected the text to be centered (align and valign) within the control.
I tested in IE5 and found that it works as I expected.

Here's the style I used

input.submit {
    color: white;
    background-color: #ff6600;
    font-family: Verdana, Arial, Helvetica, sans-serif;
    font-size: 7pt;
    font-weight: bold;
    border: white solid 2px;
    width: 3.5em;
    height: 2em;
}

Here's the control

<input type="submit" name="submit" value="GO" class="submit">
dupping forward to assigned bug.

*** This bug has been marked as a duplicate of 165329 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.