Closed Bug 1450165 Opened 2 years ago Closed 2 years ago

Assertion failure: mStartOfRightNode.Offset() == mNewLeftNode->Length(), at src/editor/libeditor/SplitNodeTransaction.cpp:114

Categories

(Core :: DOM: Editor, defect)

61 Branch
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1421743
Tracking Status
firefox61 --- affected

People

(Reporter: tsmith, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: assertion, testcase)

Attachments

(1 file, 1 obsolete file)

Attached file testcase.html (obsolete) —
Assertion failure: mStartOfRightNode.Offset() == mNewLeftNode->Length(), at src/editor/libeditor/SplitNodeTransaction.cpp:114

#0 mozilla::SplitNodeTransaction::DoTransaction() src/editor/libeditor/SplitNodeTransaction.cpp:114:5
#1 mozilla::TransactionManager::BeginTransaction(nsITransaction*, nsISupports*) src/editor/txmgr/TransactionManager.cpp:680:34
#2 mozilla::TransactionManager::DoTransaction(nsITransaction*) src/editor/txmgr/TransactionManager.cpp:71:8
#3 mozilla::EditorBase::DoTransaction(mozilla::dom::Selection*, nsITransaction*) src/editor/libeditor/EditorBase.cpp:798:32
#4 already_AddRefed<nsIContent> mozilla::EditorBase::SplitNode<nsCOMPtr<nsINode>, nsCOMPtr<nsIContent> >(mozilla::EditorDOMPointBase<nsCOMPtr<nsINode>, nsCOMPtr<nsIContent> > const&, mozilla::ErrorResult&) src/editor/libeditor/EditorBase.cpp:1500:12
#5 mozilla::SplitNodeResult mozilla::EditorBase::SplitNodeDeep<nsINode*, nsIContent*>(nsIContent&, mozilla::EditorDOMPointBase<nsINode*, nsIContent*> const&, mozilla::SplitAtEdges) src/editor/libeditor/EditorBase.cpp:4102:42
#6 mozilla::HTMLEditRules::BustUpInlinesAtRangeEndpoints(mozilla::RangeItem&) src/editor/libeditor/HTMLEditRules.cpp:6576:19
#7 mozilla::HTMLEditRules::GetNodesForOperation(nsTArray<RefPtr<nsRange> >&, nsTArray<mozilla::OwningNonNull<nsINode> >&, mozilla::EditAction, mozilla::HTMLEditRules::TouchContent) src/editor/libeditor/HTMLEditRules.cpp:6235:12
#8 mozilla::HTMLEditRules::GetNodesFromSelection(mozilla::dom::Selection&, mozilla::EditAction, nsTArray<mozilla::OwningNonNull<nsINode> >&, mozilla::HTMLEditRules::TouchContent) src/editor/libeditor/HTMLEditRules.cpp:6749:17
#9 mozilla::HTMLEditRules::WillAlign(mozilla::dom::Selection&, nsTSubstring<char16_t> const&, bool*, bool*) src/editor/libeditor/HTMLEditRules.cpp:5060:8
#10 mozilla::HTMLEditRules::WillDoAction(mozilla::dom::Selection*, mozilla::RulesInfo*, bool*, bool*) src/editor/libeditor/HTMLEditRules.cpp:654:14
#11 mozilla::HTMLEditor::Align(nsTSubstring<char16_t> const&) src/editor/libeditor/HTMLEditor.cpp:2313:24
#12 nsMultiStateCommand::DoCommandParams(char const*, nsICommandParams*, nsISupports*) src/editor/composer/nsComposerCommands.cpp:637:10
#13 nsControllerCommandTable::DoCommandParams(char const*, nsICommandParams*, nsISupports*) src/dom/commandhandler/nsControllerCommandTable.cpp:162:26
#14 nsBaseCommandController::DoCommandWithParams(char const*, nsICommandParams*) src/dom/commandhandler/nsBaseCommandController.cpp:152:25
#15 nsCommandManager::DoCommand(char const*, nsICommandParams*, mozIDOMWindowProxy*) src/dom/commandhandler/nsCommandManager.cpp:210:29
#16 nsHTMLDocument::ExecCommand(nsTSubstring<char16_t> const&, bool, nsTSubstring<char16_t> const&, nsIPrincipal&, mozilla::ErrorResult&) src/dom/html/nsHTMLDocument.cpp:2968:18
#17 mozilla::dom::HTMLDocumentBinding::execCommand(JSContext*, JS::Handle<JSObject*>, nsHTMLDocument*, JSJitMethodCallArgs const&) src/obj-firefox/dom/bindings/HTMLDocumentBinding.cpp:580:21
#18 mozilla::dom::GenericBindingMethod(JSContext*, unsigned int, JS::Value*) src/dom/bindings/BindingUtils.cpp:3032:13
#19 0x359085557c0a  (<unknown module>)
Flags: in-testsuite?
Found with:
BuildID=20180329220707
SourceStamp=dcd10220d55aea46db212314c46d25a96a7be243
Attached file testcase.html
Attachment #8963842 - Attachment is obsolete: true
I missed the previous report.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1421743
You need to log in before you can comment on or make changes to this bug.