Closed Bug 1450552 Opened 4 years ago Closed 4 years ago

Intermittent tier2 talos svgr Aborting task - max run time exceeded

Categories

(Testing :: Talos, defect)

Version 3
defect
Not set
normal

Tracking

(firefox61 fixed)

RESOLVED FIXED
mozilla61
Tracking Status
firefox61 --- fixed

People

(Reporter: apavel, Assigned: kats)

References

Details

Attachments

(1 file)

Treeherder link: ahttps://treeherder.mozilla.org/#/jobs?repo=mozilla-central&filter-resultStatus=testfailed&filter-resultStatus=busted&filter-resultStatus=exception&filter-resultStatus=success&filter-resultStatus=pending&filter-resultStatus=running&filter-classifiedState=unclassified&selectedJob=171371244&filter-searchStr=Windows%2010%20x64%20QuantumRender%20opt%20Talos%20performance%20tests%20with%20e10s%20test-windows10-64-qr%2Fopt-talos-svgr-e10s%20T-e10s(s)&group_state=expanded


Failure log: https://treeherder.mozilla.org/logviewer.html#?job_id=171362480&repo=mozilla-central

11:21:41     INFO -  TEST-INFO | started process 6688 (C:\Users\task_1522578390\build\application\firefox\firefox -profile c:\users\genericworker\appdata\local\temp\tmpz9yuly\profile)
11:21:42     INFO -  PID 6688 | WebRender - OpenGL version new OpenGL ES 3.0 (ANGLE 2.1.0.27cef491162b)
11:21:42     INFO -  PID 6688 | [GFX1-]: WR: ERROR: Invalid window dimensions 120x0. Please call api.set_window_size()
11:21:42     INFO -  PID 6688 | [GFX1-]: WR: ERROR: Invalid window dimensions 120x0. Please call api.set_window_size()
11:21:42     INFO -  PID 6688 | WebRender - OpenGL version new OpenGL ES 3.0 (ANGLE 2.1.0.27cef491162b)
11:21:42     INFO -  PID 6688 | WARN: rx::HLSLCompiler::compileToBinary(228):
11:21:42     INFO -  PID 6688 | C:\fakepath(739,32-48): warning X3556: integer divides may be much slower, try using uints if possible.
11:21:42     INFO -  PID 6688 | C:\fakepath(740,25-41): warning X3556: integer modulus may be much slower, try using uints if possible.
11:21:42     INFO -  PID 6688 | C:\fakepath(650,20-34): warning X3556: integer modulus may be much slower, try using uints if possible.
11:21:42     INFO -  PID 6688 | C:\fakepath(650,39-53): warning X3556: integer divides may be much slower, try using uints if possible.
11:21:42     INFO -  PID 6688 |
11:21:43     INFO -  PID 6688 | WARN: rx::HLSLCompiler::compileToBinary(228):
11:21:43     INFO -  PID 6688 | C:\fakepath(733,32-48): warning X3556: integer divides may be much slower, try using uints if possible.
11:21:43     INFO -  PID 6688 | C:\fakepath(734,25-41): warning X3556: integer modulus may be much slower, try using uints if possible.
11:21:43     INFO -  PID 6688 | C:\fakepath(644,20-34): warning X3556: integer modulus may be much slower, try using uints if possible.
11:21:43     INFO -  PID 6688 | C:\fakepath(644,39-53): warning X3556: integer divides may be much slower, try using uints if possible.
11:21:43     INFO -  PID 6688 |
11:21:43     INFO -  PID 6688 | WARN: rx::HLSLCompiler::compileToBinary(228):
11:21:43     INFO -  PID 6688 | C:\fakepath(584,20-34): warning X3556: integer modulus may be much slower, try using uints if possible.
11:21:43     INFO -  PID 6688 | C:\fakepath(584,39-53): warning X3556: integer divides may be much slower, try using uints if possible.
11:21:43     INFO -  PID 6688 |
11:21:43     INFO -  PID 6688 | WARN: rx::HLSLCompiler::compileToBinary(228):
11:21:43     INFO -  PID 6688 | C:\fakepath(511,20-34): warning X3556: integer modulus may be much slower, try using uints if possible.
11:21:43     INFO -  PID 6688 | C:\fakepath(511,39-53): warning X3556: integer divides may be much slower, try using uints if possible.
11:21:43     INFO -  PID 6688 |
11:21:43     INFO -  PID 6688 | WARN: rx::HLSLCompiler::compileToBinary(228):
11:21:43     INFO -  PID 6688 | C:\fakepath(506,20-34): warning X3556: integer modulus may be much slower, try using uints if possible.
11:21:43     INFO -  PID 6688 | C:\fakepath(506,39-53): warning X3556: integer divides may be much slower, try using uints if possible.
11:21:43     INFO -  PID 6688 |
11:21:43     INFO -  PID 6688 | WARN: rx::HLSLCompiler::compileToBinary(228):
11:21:43     INFO -  PID 6688 | C:\fakepath(534,20-34): warning X3556: integer modulus may be much slower, try using uints if possible.
11:21:43     INFO -  PID 6688 | C:\fakepath(534,39-53): warning X3556: integer divides may be much slower, try using uints if possible.
11:21:43     INFO -  PID 6688 |
11:21:43     INFO -  PID 6688 | WARN: rx::HLSLCompiler::compileToBinary(228):
11:21:43     INFO -  PID 6688 | C:\fakepath(764,32-48): warning X3556: integer divides may be much slower, try using uints if possible.
11:21:43     INFO -  PID 6688 | C:\fakepath(765,25-41): warning X3556: integer modulus may be much slower, try using uints if possible.
11:21:43     INFO -  PID 6688 | C:\fakepath(650,20-34): warning X3556: integer modulus may be much slower, try using uints if possible.
11:21:43     INFO -  PID 6688 | C:\fakepath(650,39-53): warning X3556: integer divides may be much slower, try using uints if possible.
11:21:43     INFO -  PID 6688 | C:\fakepath(739,55-70): warning X3556: integer divides may be much slower, try using uints if possible.
11:21:43     INFO -  PID 6688 | C:\fakepath(741,58-73): warning X3556: integer modulus may be much slower, try using uints if possible.
11:21:43     INFO -  PID 6688 |
11:21:44     INFO -  PID 6688 | overall: 0
11:21:45     INFO -  PID 6688 | overall: 0
11:21:46     INFO -  PID 6688 | overall: 0
11:21:46     INFO -  PID 6688 | overall: 0
11:21:47     INFO -  PID 6688 | overall: 0
11:21:48     INFO -  PID 6688 | overall: 0
11:21:49     INFO -  PID 6688 | overall: 0
11:21:49     INFO -  PID 6688 | overall: 0
11:21:50     INFO -  PID 6688 | overall: 0
11:21:52     INFO -  PID 6688 | overall: 0
11:21:52     INFO -  PID 6688 | TART_RESULTS_JSON=[{"name":"simple-open-DPI1.raw.TART","value":[]},{"name":"simple-open-DPI1.half.TART","value":0},{"name":"simple-open-DPI1.all.TART","value":0},{"name":"simple-open-DPI1.error.TART","value":21.109317976087368},{"name":"simple-close-DPI1.raw.TART","value":[]},{"name":"simple-close-DPI1.half.TART","value":0},{"name":"simple-close-DPI1.all.TART","value":0},{"name":"simple-close-DPI1.error.TART","value":15.206308376443303},{"name":"icon-open-DPI1.raw.TART","value":[]},{"name":"icon-open-DPI1.half.TART","value":0},{"name":"icon-open-DPI1.all.TART","value":0},{"name":"icon-open-DPI1.error.TART","value":26.507496351151985},{"name":"icon-close-DPI1.raw.TART","value":[]},{"name":"icon-close-DPI1.half.TART","value":0},{"name":"icon-close-DPI1.all.TART","value":0},{"name":"icon-close-DPI1.error.TART","value":17.90898155847117},{"name":"icon-open-DPI2.raw.TART","value":[]},{"name":"icon-open-DPI2.half.TART","value":0},{"name":"icon-open-DPI2.all.TART","value":0},{"name":"icon-open-DPI2.error.TART","value":28.483471982719493},{"name":"icon-close-DPI2.raw.TART","value":[]},{"name":"icon-close-DPI2.half.TART","value":0},{"name":"icon-close-DPI2.all.TART","value":0},{"name":"icon-close-DPI2.error.TART","value":16.325879990114117},{"name":"iconFade-close-DPI2.raw.TART","value":[]},{"name":"iconFade-close-DPI2.half.TART","value":0},{"name":"iconFade-close-DPI2.all.TART","value":0},{"name":"iconFade-close-DPI2.error.TART","value":2.539106499931222},{"name":"iconFade-open-DPI2.raw.TART","value":[]},{"name":"iconFade-open-DPI2.half.TART","value":0},{"name":"iconFade-open-DPI2.all.TART","value":0},{"name":"iconFade-open-DPI2.error.TART","value":3.810912546437976},{"name":"newtab-open-preload-no.raw.TART","value":[]},{"name":"newtab-open-preload-no.half.TART","value":0},{"name":"newtab-open-preload-no.all.TART","value":0},{"name":"newtab-open-preload-no.error.TART","value":35.6483889774081},{"name":"newtab-open-preload-yes.raw.TART","value":[]},{"name":"newtab-open-preload-yes.half.TART","value":0},{"name":"newtab-open-preload-yes.all.TART","value":0},{"name":"newtab-open-preload-yes.error.TART","value":17.941749508137946}]
11:21:52     INFO -  PID 6688 |
11:21:52     INFO -  PID 6688 | simple-open-DPI1.raw.TART:
11:21:52     INFO -  PID 6688 | simple-open-DPI1.half.TART: 0.0
11:21:52     INFO -  PID 6688 | simple-open-DPI1.all.TART: 0.0
11:21:52     INFO -  PID 6688 | simple-open-DPI1.error.TART: 21.1
11:21:52     INFO -  PID 6688 | simple-close-DPI1.raw.TART:
11:21:52     INFO -  PID 6688 | simple-close-DPI1.half.TART: 0.0
11:21:52     INFO -  PID 6688 | simple-close-DPI1.all.TART: 0.0
11:21:52     INFO -  PID 6688 | simple-close-DPI1.error.TART: 15.2
11:21:52     INFO -  PID 6688 | icon-open-DPI1.raw.TART:
11:21:52     INFO -  PID 6688 | icon-open-DPI1.half.TART: 0.0
11:21:52     INFO -  PID 6688 | icon-open-DPI1.all.TART: 0.0
11:21:52     INFO -  PID 6688 | icon-open-DPI1.error.TART: 26.5
11:21:52     INFO -  PID 6688 | icon-close-DPI1.raw.TART:
11:21:52     INFO -  PID 6688 | icon-close-DPI1.half.TART: 0.0
11:21:52     INFO -  PID 6688 | icon-close-DPI1.all.TART: 0.0
11:21:52     INFO -  PID 6688 | icon-close-DPI1.error.TART: 17.9
11:21:52     INFO -  PID 6688 | icon-open-DPI2.raw.TART:
11:21:52     INFO -  PID 6688 | icon-open-DPI2.half.TART: 0.0
11:21:52     INFO -  PID 6688 | icon-open-DPI2.all.TART: 0.0
11:21:52     INFO -  PID 6688 | icon-open-DPI2.error.TART: 28.5
11:21:52     INFO -  PID 6688 | icon-close-DPI2.raw.TART:
11:21:52     INFO -  PID 6688 | icon-close-DPI2.half.TART: 0.0
11:21:52     INFO -  PID 6688 | icon-close-DPI2.all.TART: 0.0
11:21:52     INFO -  PID 6688 | icon-close-DPI2.error.TART: 16.3
11:21:52     INFO -  PID 6688 | iconFade-close-DPI2.raw.TART:
11:21:52     INFO -  PID 6688 | iconFade-close-DPI2.half.TART: 0.0
11:21:52     INFO -  PID 6688 | iconFade-close-DPI2.all.TART: 0.0
11:21:52     INFO -  PID 6688 | iconFade-close-DPI2.error.TART: 2.5
11:21:52     INFO -  PID 6688 | iconFade-open-DPI2.raw.TART:
11:21:52     INFO -  PID 6688 | iconFade-open-DPI2.half.TART: 0.0
11:21:52     INFO -  PID 6688 | iconFade-open-DPI2.all.TART: 0.0
11:21:52     INFO -  PID 6688 | iconFade-open-DPI2.error.TART: 3.8
11:21:52     INFO -  PID 6688 | newtab-open-preload-no.raw.TART:
11:21:52     INFO -  PID 6688 | newtab-open-preload-no.half.TART: 0.0
11:21:52     INFO -  PID 6688 | newtab-open-preload-no.all.TART: 0.0
11:21:52     INFO -  PID 6688 | newtab-open-preload-no.error.TART: 35.6
11:21:52     INFO -  PID 6688 | newtab-open-preload-yes.raw.TART:
11:21:52     INFO -  PID 6688 | newtab-open-preload-yes.half.TART: 0.0
11:21:52     INFO -  PID 6688 | newtab-open-preload-yes.all.TART: 0.0
11:21:52     INFO -  PID 6688 | newtab-open-preload-yes.error.TART: 17.9
11:21:52     INFO -  PID 6688 | Cycle 1(1): loaded chrome://tart/content/tart.html#auto (next: chrome://tart/content/tart.html#auto)
11:21:52     INFO -  PID 6688 | Waiting for idle-callback
[taskcluster 2018-04-01T11:42:57.253Z] Aborting task - max run time exceeded!
[taskcluster 2018-04-01T11:42:57.562Z]   Exit Code: 0
[taskcluster 2018-04-01T11:42:57.562Z]   User Time: 0s
[taskcluster 2018-04-01T11:42:57.562Z] Kernel Time: 0s
[taskcluster 2018-04-01T11:42:57.562Z]   Wall Time: 29m55.9411112s
[taskcluster 2018-04-01T11:42:57.562Z] Peak Memory: 4984832
[taskcluster 2018-04-01T11:42:57.562Z]      Result: IDLENESS_LIMIT_EXCEEDED
[taskcluster 2018-04-01T11:42:57.562Z] === Task Finished ===
[taskcluster 2018-04-01T11:42:57.562Z] Task Duration: 29m55.9530651s
:kats, should this be running on windows10-qr builds?  If so, anything I can do to help out?  this seems to be closer to a perma fail from what I saw.
Flags: needinfo?(bugmail)
It used to be green, but at some point while it was disabled (during the new windows 10 hardware migration landing/backout) it seems to have regressed. I'll disable this for now and investigate when I get a chance.
Assignee: nobody → bugmail
Flags: needinfo?(bugmail)
Comment on attachment 8964904 [details]
Bug 1450552 - Disable svgr on windows10-64-qr for almost-permafailing.

https://reviewboard.mozilla.org/r/233646/#review239242

thanks- looking forward to this turning back on soon.
Attachment #8964904 - Flags: review?(jmaher) → review+
Will use bug 1451305 to track re-enabling it.
Pushed by kgupta@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7462fb5a5bdb
Disable svgr on windows10-64-qr for almost-permafailing. r=jmaher
Duplicate of this bug: 1450470
https://hg.mozilla.org/mozilla-central/rev/7462fb5a5bdb
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla61
You need to log in before you can comment on or make changes to this bug.