regxpcom creates ~/.mozilla directory with euid on FreeBSD

RESOLVED DUPLICATE of bug 52653

Status

()

Core
XPCOM
RESOLVED DUPLICATE of bug 52653
16 years ago
16 years ago

People

(Reporter: Hung-Te Lin, Assigned: dougt)

Tracking

Trunk
x86
FreeBSD
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
I've got this bug on FreeBSD, but I'm not sure if it is a FreeBSD-only bug or not.

If I have an account (eg: john) which is not root
with no ~/.mozilla yet
and I want to complete Mozilla XPCOM/chrome registeration,
I'd run 'sudo regxpcom' with some environment variables set.

But on 1.0rc2 (not on 0.99), after running the regxpcom
it also creates a ~/.mozilla directory which is empty
and owner is root. So Mozilla couldn't start up for that
user because it couldn't write to ~/.mozilla.

I think this is a bug which should be solved before 1.0 release,
or installing from FreeBSD ports will have problem.

Comment 1

16 years ago
access("/tmp/RXPC/.mozilla",0)                   = 0 (0x0)
stat("/tmp/RXPC/.mozilla/plugins",0xbfbff1e8)    ERR#2 'No such file or directory'
stat("/tmp/RXPC/.mozilla/plugins",0xbfbff238)    ERR#2 'No such file or directory'

I thought that we had a bug about this.

for 1.0 i'll probably relnote that you should not use sudo :)

*** This bug has been marked as a duplicate of 52653 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.