Closed Bug 1450609 Opened 3 years ago Closed 3 years ago

Crash in [@ mozilla::wr::IpcResourceUpdateQueue::AddBlobImage] due to MOZ_RELEASE_ASSERT(aDescriptor.width > 0 && aDescriptor.height > 0)

Categories

(Core :: Graphics: WebRender, defect, P1)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1450307
Tracking Status
firefox-esr52 --- unaffected
firefox59 --- unaffected
firefox60 --- unaffected
firefox61 --- disabled

People

(Reporter: emilio, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: crash, topcrash)

Crash Data

I'm hitting this assertion reliably when going to https://github.com/notifications.

There are a few related intermittents that don't seem to be getting much attention. Not sure if there's anything particularly interesting to my profile, but let me know if I can help debug this.

https://crash-stats.mozilla.com/report/index/316c207b-60dd-4d81-a8a3-8447f0180402
Crash Signature: [@ mozilla::wr::IpcResourceUpdateQueue::AddBlobImage ]
Duplicate of this bug: 1450851
Duplicate of this bug: 1450776
Keywords: crash
See Also: → 1446286
Btw this is a new topcrash for Firefox Nightly builds and currently ranked at #7.

https://crash-stats.mozilla.com/signature/?product=Firefox&version=61.0a1&signature=mozilla%3A%3Awr%3A%3AIpcResourceUpdateQueue%3A%3AAddBlobImage&date=%3E%3D2018-03-27T10%3A54%3A15.000Z&date=%3C2018-04-03T10%3A54%3A15.000Z&_columns=date&_columns=product&_columns=version&_columns=build_id&_columns=platform&_columns=reason&_columns=address&_columns=install_time&_sort=-date&page=1#summary

As it looks like it started with the build 20180330100123.

Emilio, are you sure this is webrender related? I ask because I see lots of other bugs filed with this signature for various test jobs in automation which certainly should not have webrender enabled:

https://crash-stats.mozilla.com/signature/?product=Firefox&version=61.0a1&signature=mozilla%3A%3Awr%3A%3AIpcResourceUpdateQueue%3A%3AAddBlobImage&date=%3E%3D2018-03-01T11%3A55%3A00.000Z&date=%3C2018-04-03T13%3A55%3A30.000Z#bugzilla
Severity: normal → critical
Flags: needinfo?(emilio)
Summary: Crash in mozilla::wr::IpcResourceUpdateQueue::AddBlobImage: MOZ_RELEASE_ASSERT(aDescriptor.width > 0 && aDescriptor.height > 0) → Crash in [@ mozilla::wr::IpcResourceUpdateQueue::AddBlobImage] due to MOZ_RELEASE_ASSERT(aDescriptor.width > 0 && aDescriptor.height > 0)
Please drop the ni? on my last comment. I just checked and the related bugs are from test jobs which run for QuantumRender.
Flags: needinfo?(emilio)
mozilla::wr:: are webrender-only crash signatures. bug 1447076 introduced a new assert (aDescriptor.width > 0 && aDescriptor.height > 0) and made some crashes of bug 1446286 look like bug 1447076 comment 13. The first reported intermittent failure of this new crash signature is bug 1450157. Intermittent bugs seem to be handled separately in the past, so I didn't touch them.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1450307
You need to log in before you can comment on or make changes to this bug.