Closed Bug 1450671 Opened 2 years ago Closed 2 years ago

Coordinates are not being highlighted on hover after editing unfocused shape

Categories

(DevTools :: Inspector, defect)

defect
Not set

Tracking

(firefox61 affected)

RESOLVED WONTFIX
Tracking Status
firefox61 --- affected

People

(Reporter: david.olah, Unassigned)

References

(Blocks 1 open bug)

Details

[Affected versions]: 
Nightly 61.0a1

[Affected platforms]:
Platforms: Windows 10 x 64, Windows 7 x 32, Mac OS X 10.12 and Ubuntu 16.04 x64.

[Steps to reproduce]:
1. Go to about:config and set "layout.css.shape-outside.enabled" to true.
2. Go to http://labs.jensimmons.com/2016/examples/shapes-3.html
3. Right click on the image and then click on "Inspect Element".
4. Click on the button displayed next to clip-path to toggle the shape tool on
5. Inspect a different element to unfocus the shape
6. Without being focused, modify a point from the shape above
7. Inspect the shape again so you can see the coordinates in the Rules from inspect element
8. Hover the mouse on a point from the shape

[Expected result]:
- The coordinate from the Rules in Inspect element of the hovered point is highlighted

[Actual result]:
- The coordinate from the Rules in Inspect element of the hovered point doesn't highlight
It looks like as soon as you select another element, and then select the image again, the highlight-on-hover doesn't work anymore.
It works in the rule-view -> overlay direction, but in the overlay -> rule-view, it doesn't.

Razvan, this bug will go away with bug 1435373, right? If I remember correctly, with this bug as soon as another element is selected, we stop editing the shape.
Flags: needinfo?(rcaliman)
Discussing this with Martin at the moment on Slack. Let me needinfo him here too so we can capture the discussion and decision here.
Flags: needinfo?(mbalfanz)
> Razvan, this bug will go away with bug 1435373, right? If I remember correctly, with this bug as soon as another element is selected, we stop editing the shape.

Correct. When the user selects another element, the shape highlighter will turn off. The conditions for this bug will no longer occur.
Flags: needinfo?(rcaliman)
(In reply to Razvan Caliman [:rcaliman][@rcaliman] from comment #3)
> > Razvan, this bug will go away with bug 1435373, right? If I remember correctly, with this bug as soon as another element is selected, we stop editing the shape.
> 
> Correct. When the user selects another element, the shape highlighter will
> turn off. The conditions for this bug will no longer occur.

This sounds good to me and is consistent with other "editor"-type tools we currently have.
Flags: needinfo?(mbalfanz)
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
See Also: → 1435373
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.