Intermittent browser_appid_localhost.js,browser_jsonview_copy_headers.js,browser_sanitize-formhistory.js,browser_favicon_load.js | A promise chain failed to handle a rejection: this.store.getState(...).Sections.find(...) is undefined

RESOLVED FIXED in Firefox 61

Status

()

defect
P1
normal
RESOLVED FIXED
a year ago
a year ago

People

(Reporter: intermittent-bug-filer, Assigned: andreio)

Tracking

({intermittent-failure})

unspecified
Firefox 61
Points:
---

Firefox Tracking Flags

(firefox61 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

a year ago
treeherder
Filed by: archaeopteryx [at] coole-files.de

https://treeherder.mozilla.org/logviewer.html#?job_id=171505500&repo=autoland

https://queue.taskcluster.net/v1/task/b7dq7ROQQhOmyM4-6QG2KA/runs/0/artifacts/public/logs/live_backing.log

[task 2018-04-02T22:15:55.882Z] 22:15:55     INFO - TEST-PASS | browser/base/content/test/favicons/browser_favicon_load.js | Should have correct cos flag. - 
[task 2018-04-02T22:15:55.885Z] 22:15:55     INFO - classFlags=288
[task 2018-04-02T22:15:55.886Z] 22:15:55     INFO - TEST-PASS | browser/base/content/test/favicons/browser_favicon_load.js | Should have correct cos flag. - 
[task 2018-04-02T22:15:55.888Z] 22:15:55     INFO - Buffered messages finished
[task 2018-04-02T22:15:55.891Z] 22:15:55     INFO - TEST-UNEXPECTED-FAIL | browser/base/content/test/favicons/browser_favicon_load.js | A promise chain failed to handle a rejection: this.store.getState(...).Sections.find(...) is undefined - stack: fetchHighlights@resource://activity-stream/lib/HighlightsFeed.jsm:163:27
[task 2018-04-02T22:15:55.894Z] 22:15:55     INFO - async*onAction@resource://activity-stream/lib/HighlightsFeed.jsm:217:9
[task 2018-04-02T22:15:55.894Z] 22:15:55     INFO - _middleware/</<@resource://activity-stream/lib/Store.jsm:49:11
[task 2018-04-02T22:15:55.895Z] 22:15:55     INFO - Store/this[method]@resource://activity-stream/lib/Store.jsm:28:55
[task 2018-04-02T22:15:55.895Z] 22:15:55     INFO - refresh@resource://activity-stream/lib/TopSitesFeed.jsm:180:7
[task 2018-04-02T22:15:55.896Z] 22:15:55     INFO - async*onAction@resource://activity-stream/lib/TopSitesFeed.jsm:377:9
[task 2018-04-02T22:15:55.896Z] 22:15:55     INFO - _middleware/</<@resource://activity-stream/lib/Store.jsm:49:11
[task 2018-04-02T22:15:55.897Z] 22:15:55     INFO - Store/this[method]@resource://activity-stream/lib/Store.jsm:28:55
[task 2018-04-02T22:15:55.897Z] 22:15:55     INFO - init@resource://activity-stream/lib/Store.jsm:136:7
[task 2018-04-02T22:15:55.898Z] 22:15:55     INFO - init@resource://activity-stream/lib/ActivityStream.jsm:289:7
[task 2018-04-02T22:15:55.899Z] 22:15:55     INFO - init@resource://gre/modules/addons/XPIProvider.jsm -> jar:file:///builds/worker/workspace/build/application/firefox/browser/features/activity-stream@mozilla.org.xpi!/bootstrap.js:64:5
[task 2018-04-02T22:15:55.900Z] 22:15:55     INFO - onBrowserReady@resource://gre/modules/addons/XPIProvider.jsm -> jar:file:///builds/worker/workspace/build/application/firefox/browser/features/activity-stream@mozilla.org.xpi!/bootstrap.js:121:3
[task 2018-04-02T22:15:55.901Z] 22:15:55     INFO - observe/<@resource://gre/modules/addons/XPIProvider.jsm -> jar:file:///builds/worker/workspace/build/application/firefox/browser/features/activity-stream@mozilla.org.xpi!/bootstrap.js:147:46
[task 2018-04-02T22:15:55.903Z] 22:15:55     INFO - Rejection date: Mon Apr 02 2018 22:15:54 GMT+0000 (UTC) - false == true - JS frame :: resource://testing-common/PromiseTestUtils.jsm :: assertNoUncaughtRejections :: line 257
[task 2018-04-02T22:15:55.904Z] 22:15:55     INFO - Stack trace:
[task 2018-04-02T22:15:55.905Z] 22:15:55     INFO -     resource://testing-common/PromiseTestUtils.jsm:assertNoUncaughtRejections:257
[task 2018-04-02T22:15:55.906Z] 22:15:55     INFO -     chrome://mochikit/content/browser-test.js:Tester_execTest/<:1098
[task 2018-04-02T22:15:55.907Z] 22:15:55     INFO -     Tester_execTest@chrome://mochikit/content/browser-test.js:1067:9
[task 2018-04-02T22:15:55.911Z] 22:15:55     INFO -     Tester.prototype.nextTest</<@chrome://mochikit/content/browser-test.js:967:9
[task 2018-04-02T22:15:55.912Z] 22:15:55     INFO -     SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<@chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:795:59
[task 2018-04-02T22:15:55.913Z] 22:15:55     INFO - Not taking screenshot here: see the one that was previously logged
Summary: Intermittent browser_sanitize-formhistory.js,browser_favicon_load.js | A promise chain failed to handle a rejection: this.store.getState(...).Sections.find(...) is undefined → Intermittent browser_appid_localhost.js,browser_sanitize-formhistory.js,browser_favicon_load.js | A promise chain failed to handle a rejection: this.store.getState(...).Sections.find(...) is undefined
Comment hidden (Intermittent Failures Robot)
Summary: Intermittent browser_appid_localhost.js,browser_sanitize-formhistory.js,browser_favicon_load.js | A promise chain failed to handle a rejection: this.store.getState(...).Sections.find(...) is undefined → Intermittent browser_appid_localhost.js,browser_jsonview_copy_headers.js,browser_sanitize-formhistory.js,browser_favicon_load.js | A promise chain failed to handle a rejection: this.store.getState(...).Sections.find(...) is undefined
(Assignee)

Updated

a year ago
Assignee: nobody → andrei.br92

Updated

a year ago
Duplicate of this bug: 1453109

Updated

a year ago
Duplicate of this bug: 1454212
Comment hidden (Intermittent Failures Robot)

Updated

a year ago
Duplicate of this bug: 1454219

Updated

a year ago
Duplicate of this bug: 1454217
Duplicate of this bug: 1454472

Updated

a year ago
Duplicate of this bug: 1451607

Updated

a year ago
Duplicate of this bug: 1454135

Comment 11

a year ago
andreio, given that there's so many ways this exception is being triggered, we should at least prevent it from causing all these related intermittents. Have you been able to reproduce the issue in any perhaps with any of these duplicates? If not, we might just land your quick fix for now hopefully not just covering up an actual bug.
Flags: needinfo?(andrei.br92)
Priority: P5 → P1

Updated

a year ago
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED

Updated

a year ago
Duplicate of this bug: 1455207

Comment 15

a year ago
Specially leaving this open so it can be starred from treeherder
Status: RESOLVED → REOPENED
Flags: needinfo?(andrei.br92)
Resolution: FIXED → ---

Updated

a year ago
Blocks: 1455216
Duplicate of this bug: 1455239

Comment 17

a year ago
https://hg.mozilla.org/mozilla-central/rev/5d2486077e4b
Status: REOPENED → RESOLVED
Iteration: --- → 61.3 - Apr 23
Last Resolved: a year agoa year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 61
Comment hidden (Intermittent Failures Robot)
You need to log in before you can comment on or make changes to this bug.