Personal toolbar menu crashes

VERIFIED WORKSFORME

Status

()

Core
XUL
P3
critical
VERIFIED WORKSFORME
18 years ago
18 years ago

People

(Reporter: Phil Peterson, Assigned: saari (gone))

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
I clicked on folder in my personal toolbar and crashed in
nsMenuFrame::UpdateDismissalListener because aMenuParent was null. Here's the
stack trace:

nsMenuFrame::UpdateDismissalListener(nsIMenuParent * 0x00000000) line 1106 + 3
bytes
nsMenuFrame::OpenMenuInternal(int 0x00000001) line 447 + 14 bytes
nsMenuFrame::AttributeChanged(nsMenuFrame * const 0x0126fba0, nsIPresContext *
0x00f85ba0, nsIContent * 0x016d55f0, nsIAtom * 0x00bec390, int 0x00000002) line
391
nsCSSFrameConstructor::AttributeChanged(nsCSSFrameConstructor * const
0x00fafa40, nsIPresContext * 0x00f85ba0, nsIContent * 0x016d55f0, nsIAtom *
0x00bec390, int 0x00000002) line 6818 + 31 bytes
StyleSetImpl::AttributeChanged(StyleSetImpl * const 0x00fafae0, nsIPresContext *
0x00f85ba0, nsIContent * 0x016d55f0, nsIAtom * 0x00bec390, int 0xffffffff) line
918
PresShell::AttributeChanged(PresShell * const 0x00faf938, nsIDocument *
0x00f84cf0, nsIContent * 0x016d55f0, nsIAtom * 0x00bec390, int 0xffffffff) line
1705 + 53 bytes
XULDocumentImpl::AttributeChanged(XULDocumentImpl * const 0x00f84cf0, nsIContent
* 0x016d55f0, nsIAtom * 0x00bec390, int 0xffffffff) line 2152
RDFElementImpl::SetAttribute(RDFElementImpl * const 0x016d55f0, int 0x00000000,
nsIAtom * 0x00bec390, const nsString & {...}, int 0x00000001) line 2427
RDFElementImpl::SetAttribute(RDFElementImpl * const 0x016d55e0, const nsString &
{...}, const nsString & {...}) line 1211 + 35 bytes
nsMenuFrame::OpenMenu(nsMenuFrame * const 0x01271680, int 0x00000001) line 420 +
63 bytes
nsMenuFrame::ToggleMenuState(nsMenuFrame * const 0x0126fba0) line 307
nsMenuFrame::HandleEvent(nsMenuFrame * const 0x0126fba0, nsIPresContext & {...},
nsGUIEvent * 0x0012fbc8, nsEventStatus & nsEventStatus_eConsumeDoDefault) line
232
PresShell::HandleEvent(PresShell * const 0x00faf934, nsIView * 0x00fafd50,
nsGUIEvent * 0x0012fbc8, nsEventStatus & nsEventStatus_eConsumeDoDefault) line
2083 + 38 bytes
nsView::HandleEvent(nsView * const 0x00fafd50, nsGUIEvent * 0x0012fbc8, unsigned
int 0x0000001c, nsEventStatus & nsEventStatus_eConsumeDoDefault, int &
0x00000000) line 828
nsViewManager::DispatchEvent(nsViewManager * const 0x00faff20, nsGUIEvent *
0x0012fbc8, nsEventStatus & nsEventStatus_eConsumeDoDefault) line 1667
HandleEvent(nsGUIEvent * 0x0012fbc8) line 63
nsWindow::DispatchEvent(nsWindow * const 0x00fafc14, nsGUIEvent * 0x0012fbc8,
nsEventStatus & nsEventStatus_eIgnore) line 338 + 10 bytes
nsWindow::DispatchWindowEvent(nsGUIEvent * 0x0012fbc8) line 359
nsWindow::DispatchMouseEvent(unsigned int 0x0000012e, nsPoint * 0x00000000) line
3224 + 21 bytes
ChildWindow::DispatchMouseEvent(unsigned int 0x0000012e, nsPoint * 0x00000000)
line 3442
nsWindow::ProcessMessage(unsigned int 0x00000201, unsigned int 0x00000001, long
0x005b0178, long * 0x0012fdec) line 2453 + 24 bytes
nsWindow::WindowProc(HWND__ * 0x0f4903f4, unsigned int 0x00000201, unsigned int
0x00000001, long 0x005b0178) line 454 + 27 bytes
USER32! 77e71820()
005b0178()
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: M11

Updated

18 years ago
QA Contact: beppe → claudius

Comment 1

18 years ago
Has anyone seen this in the last month?  I can't reproduce on Win98, can someone
try on NT and resolve as wfm if it isn't happening?  Phil, if you're the only
one seeing this, could you attach your bookmarks.html file?

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 2

18 years ago
I have not seen this in quite some time and I bang on the personal toolbar(WinNT) all day long.
marking and verifying WFM. phil please reopen if you can reproduce.

Comment 3

18 years ago
VERIFIED works for me.
You need to log in before you can comment on or make changes to this bug.