The Page Down/Up keys doesn't work after pressing Home/End keys

RESOLVED FIXED in Firefox 62

Status

RESOLVED FIXED
8 months ago
5 months ago

People

(Reporter: roxana.leitan, Assigned: mtigley, Mentored)

Tracking

(Blocks: 1 bug)

61 Branch
Firefox 62

Firefox Tracking Flags

(firefox61 wontfix, firefox62 fixed)

Details

(Whiteboard: [good first verify])

Attachments

(1 attachment)

(Reporter)

Description

8 months ago
[Affected versions]:
Nightly 61.0a1

[Affected Platforms]:
Ubuntu 16.04 x64, Windows 10 x64

[Prerequisites]:
- Have the latest try build 61.0a1 from (2018-03-27) installed.
- Accessibility is enabled and accessibility tab is opened

[Steps to reproduce]:
1.Click on down arrows from Role area to expand until the scrollbar is displayed on the right side of the panel
2.Press End key
3.Press Home key
4.Press Page down key

[Expected result]:
The Role content area should be scrolled down

[Actual result]:
Nothing happens

Comment 1

8 months ago
[Affected versions]:
Latest Nightly 61.0a1, Build ID: 20180410100115

[Affected Platforms]:
Windows 10 x64

Further testing revealed that the issue could be reproduced also with the "Home" and "End" keys if the Page Up/Page down keys are pressed before. 

[Steps to reproduce]:
1. Click on down arrows from Role area to expand until the scrollbar is displayed on the right side of the panel
2. Press Home key
3. Press Page Down key once
4. Press Home key 
5. Observe the issue
6. Repeat the steps by replacing Home and Page Down with End key and Page Up key
(Assignee)

Updated

6 months ago
Assignee: nobody → mtigley
Status: NEW → ASSIGNED
Comment hidden (mozreview-request)

Comment 3

6 months ago
mozreview-review
Comment on attachment 8983840 [details]
Bug 1450930 - The Page Down/Up keys doesn't work after pressing Home/End keys.

https://reviewboard.mozilla.org/r/249656/#review256328

This looks good. We might want to open a new bug for improving scroll into view overall, where we would only scroll if necessary.
Attachment #8983840 - Flags: review?(yzenevich) → review+
Attachment #8983840 - Flags: review?(odvarko)
I can't reproduce the reported issue on my machine (Win10, Firefox m-c)

Here is what I am doing:

1) load any page
2) open the Accessibility panel and click on "Turn On Accessibility Features" 
3) Clicking on the "Document" entry in the Role area (to make sure the focus is there), but not on the arrow, so it stays collapsed.
4) Pressing arrow-right key to expand the entry (not arrow-down as indicated in comment #0)
5) Pressing arrow-down to move down in the list and expanding other entries to make sure the vertical scrollbar appears
6) Pressing Home properly selects the first entry ("document") and scrolls to the top, so the selection is visible
7) Pressing End properly selects the last entry and scrolls to the bottom, so the selection is visible
8) Pressing PageUp scrolls up one page, but doesn't change the selection
9) Pressing PageDown scrolls down one page, but doesn't change the selection

Where is the problem?
What am I doing wrong?

Honza
Flags: needinfo?(yzenevich)
(In reply to Jan Honza Odvarko [:Honza] from comment #4)
> I can't reproduce the reported issue on my machine (Win10, Firefox m-c)
> 
> Here is what I am doing:
> 
> 1) load any page
> 2) open the Accessibility panel and click on "Turn On Accessibility
> Features" 
> 3) Clicking on the "Document" entry in the Role area (to make sure the focus
> is there), but not on the arrow, so it stays collapsed.
> 4) Pressing arrow-right key to expand the entry (not arrow-down as indicated
> in comment #0)
> 5) Pressing arrow-down to move down in the list and expanding other entries
> to make sure the vertical scrollbar appears
> 6) Pressing Home properly selects the first entry ("document") and scrolls
> to the top, so the selection is visible

After this step try:

* Press PageDown (so the first element is out of sight), nothing new is selected.
* Press Home again, the scroll does not happen because we have a check for current selection and stop if it does not change (which it did not, since the first element is always selected).

> 7) Pressing End properly selects the last entry and scrolls to the bottom,
> so the selection is visible
> 8) Pressing PageUp scrolls up one page, but doesn't change the selection
> 9) Pressing PageDown scrolls down one page, but doesn't change the selection
> 
> Where is the problem?
> What am I doing wrong?
> 
> Honza
Flags: needinfo?(yzenevich)

Updated

6 months ago
Product: Firefox → DevTools

Comment 6

6 months ago
mozreview-review
Comment on attachment 8983840 [details]
Bug 1450930 - The Page Down/Up keys doesn't work after pressing Home/End keys.

https://reviewboard.mozilla.org/r/249656/#review257908

I was able to repro the issue using STR in comment #5

Looks good and works for me.
R+ assuming Try is green

Thanks for the patch!

Honza
Attachment #8983840 - Flags: review?(odvarko) → review+
(Assignee)

Updated

6 months ago
Mentor: yzenevich
Keywords: checkin-needed

Comment 8

6 months ago
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/40b467f38306
The Page Down/Up keys doesn't work after pressing Home/End keys. r=Honza,yzen
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/40b467f38306
Status: ASSIGNED → RESOLVED
Last Resolved: 6 months ago
status-firefox62: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 62
status-firefox61: affected → wontfix
Whiteboard: [good first verify]
You need to log in before you can comment on or make changes to this bug.