Closed Bug 1450980 Opened Last year Closed Last year

The Highlighter will disappear from iFrame after refresh [DevTools Shaping Tool]

Categories

(DevTools :: Inspector, defect)

61 Branch
defect
Not set

Tracking

(firefox61 affected)

RESOLVED WONTFIX
Tracking Status
firefox61 --- affected

People

(Reporter: rares.doghi, Unassigned)

References

(Blocks 1 open bug)

Details

[Affected versions]:
- Nightly 61.0a1

[Affected platforms]:
- Platforms: Windows 10 x 64, Windows 7 x 32, Mac OS X 10.12 and Ubuntu 16.04 x64.

[Steps to reproduce]:
1. 1. Go to about:config and set "layout.css.shape-outside.enabled" to true.
2. Go to "https://drive.google.com/file/d/1OAi1kGbuyu4qR35sOG0wM5Ru6JtvGgh7/view?usp=sharing" downloaded it in .html format and open it with Firefox.
3. Right click on the image and then click on "Inspect Element".
4. Click on the button displayed next to clip-path to toggle the shape tool on.
5. Refresh the Page.


[Expected result]:
- The Highlighter should be displayed in iFrame after the page reloads.

[Actual result]:
- The Highlighter is no longer displayed after the page will refresh.
Blocks: 1242029
Please Note that if the image is not in an iFrame the issue does not occur and the Highlighter is displayed after Refresh.
I can confirm that this is happening indeed. However the link to the test page is incorrect:
- it contains no iframe
- comment 0 says to click on clip-path, but the test case contains a shape-outside property instead

I'm not sure what to do with this bug, I don't think we ever discussed the value or re-highlighting the shape after a page reload. Should we keep on doing it and fix it when it's in an iframe? Or remove this?
Flags: needinfo?(rcaliman)
(In reply to Patrick Brosset <:pbro> from comment #2)
> I can confirm that this is happening indeed. However the link to the test
> page is incorrect:
> - it contains no iframe
> - comment 0 says to click on clip-path, but the test case contains a
> shape-outside property instead
> 
> I'm not sure what to do with this bug, I don't think we ever discussed the
> value or re-highlighting the shape after a page reload. Should we keep on
> doing it and fix it when it's in an iframe? Or remove this?

Hello, sorry for the confusion , here is the correct link where you an find an image inside an iFrame, Please download this one instead.

Thanks,
Rares
Go to : "https://drive.google.com/file/d/1zAOwoVHBDk8RmX97N7lvvdbd5KPWRk6u/view?usp=sharing" downloaded it in .html formate and open it with Firefox, Make sure the element is inside the iframe.
When Bug 1435373 lands (https://bugzilla.mozilla.org/show_bug.cgi?id=1435373) the behaviour will be that shape highlighting will not be restored in any case after refresh. The user will have to click the toggle icon again.

This stems from added complexity in identifying the rule and CSS declaration where the shape highlighter should map its changes to. Right now (until Bug 1435373 lands), changes are mapped to inline styles therefore making shape highlighting restore practical because there's a unique entry in Rule view for inline styles.

Other highlighters do not have this constraint brought by in-context editing capabilities and can restore highlight after refresh.
Flags: needinfo?(rcaliman)
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → WONTFIX
See Also: → 1435373
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.