Closed Bug 1450999 Opened 2 years ago Closed 2 years ago

Browser Toolbox can't be resized

Categories

(DevTools :: General, defect, blocker)

defect
Not set
blocker

Tracking

(firefox-esr52 unaffected, firefox59 unaffected, firefox60 unaffected, firefox61 fixed)

RESOLVED FIXED
Firefox 61
Tracking Status
firefox-esr52 --- unaffected
firefox59 --- unaffected
firefox60 --- unaffected
firefox61 --- fixed

People

(Reporter: standard8, Assigned: florian)

References

Details

(Keywords: regression)

Attachments

(1 file)

I think as of today's nightly, the browser toolbox can't be resized. I'm pretty sure I was using it last night or this morning, and it was fine.

STR:

1) Start latest Firefox, either a self-build or a nightly
2) Open the browser Toolbox
3) Attempt to resize it.

=> Can't resize, the cursor never changes to <->

I'm on a Mac 10.13.4
I see the same on OSX in a local build at c44f60c43432
Attached patch PatchSplinter Review
This patch reverts to the previous behavior. The old openWindow function from nsBrowserContent.js always provided 4 null arguments when opening a window. The C++ openWindow implementation behaves differently if the arg count is 0, at https://searchfox.org/mozilla-central/rev/f860c2bf00576959b07e2d9619c7b5088b0005be/toolkit/components/windowwatcher/nsWindowWatcher.cpp#326

The comment at https://searchfox.org/mozilla-central/rev/f860c2bf00576959b07e2d9619c7b5088b0005be/toolkit/components/windowwatcher/nsWindowWatcher.cpp#409-411 starting with "This is extremely messed up" makes me want to insert a hack to cowardly revert to the old behavior instead of trying to further disentangle how arguments are handled when opening windows.
Attachment #8965335 - Flags: review?(mconley)
Assignee: nobody → florian
Status: NEW → ASSIGNED
Comment on attachment 8965335 [details] [diff] [review]
Patch

Review of attachment 8965335 [details] [diff] [review]:
-----------------------------------------------------------------

Ooof. :/ Thanks for finding and fixing this.
Attachment #8965335 - Flags: review?(mconley) → review+
Pushed by florian@queze.net:
https://hg.mozilla.org/integration/mozilla-inbound/rev/ed4586ca3284
always provide a null argument when opening a window for the -chrome command line parameter, otherwise the opened window is non-resizable, r=mconley.
https://hg.mozilla.org/mozilla-central/rev/ed4586ca3284
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 61
Duplicate of this bug: 1453419
Flags: needinfo?(florian)
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.