Closed Bug 1451034 Opened 4 years ago Closed 4 years ago

Make aushelper something other than a bootstrapped extension

Categories

(Toolkit :: Application Update, enhancement)

enhancement
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1358342

People

(Reporter: aswan, Unassigned)

Details

No description provided.
Robert, do we still depend on aushelper?  We're working toward removing support for bootstrapped extensions so if it is still needed we can either:
1. Move the code into a built-in browser component (eg stick it in nsBrowserGlue.js or something)
2. Convert it to a webextension with a bundled experiment that can handle the registry and preference bits.

So, question for you is do we still need it and if so, do we need to be able to ship out-of-cycle updates to it?
Flags: needinfo?(robert.strong.bugs)
There is already bug 1358342 to move what's needed into UpdateUtils.jsm and bug 1426389 to remove what isn't needed anymore
Flags: needinfo?(robert.strong.bugs)
No longer blocks: 1449052
Ah, thanks
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1358342
You need to log in before you can comment on or make changes to this bug.