Closed Bug 1451065 Opened 3 years ago Closed 3 years ago

Require Python 3.5 on some build configurations

Categories

(Firefox Build System :: General, enhancement)

3 Branch
enhancement
Not set
normal

Tracking

(firefox61 fixed)

RESOLVED FIXED
mozilla61
Tracking Status
firefox61 --- fixed

People

(Reporter: gps, Assigned: gps)

References

Details

Attachments

(3 files)

No description provided.
Attachment #8964639 - Flags: review?(core-build-config-reviews)
Comment on attachment 8964640 [details]
Bug 1451065 - Attempt to install Python 3 on Debian distros;

https://reviewboard.mozilla.org/r/233342/#review244002
Attachment #8964640 - Flags: review+
Attachment #8964640 - Flags: review?(core-build-config-reviews)
Comment on attachment 8964641 [details]
Bug 1451065 - Require Python 3.5+ to build;

https://reviewboard.mozilla.org/r/233344/#review244004
Attachment #8964641 - Flags: review+
Attachment #8964641 - Flags: review?(core-build-config-reviews)
Pushed by gszorc@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/835775164d3f
Install Python 3 on Arch; r=mshal
https://hg.mozilla.org/integration/autoland/rev/6c443e883ed4
Attempt to install Python 3 on Debian distros; r=mshal
https://hg.mozilla.org/integration/autoland/rev/af5755fcc488
Require Python 3.5+ to build; r=mshal
https://hg.mozilla.org/mozilla-central/rev/835775164d3f
https://hg.mozilla.org/mozilla-central/rev/6c443e883ed4
https://hg.mozilla.org/mozilla-central/rev/af5755fcc488
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla61
Blocks: buildpython3
Blocks: 1455708
Depends on: 1457765
Version: Version 3 → 3 Branch
You need to log in before you can comment on or make changes to this bug.