Closed Bug 1451173 Opened 5 years ago Closed 3 years ago

Intermittent /html/browsers/browsing-the-web/navigating-across-documents/javascript-url-abort/javascript-url-abort-return-value-string.tentative.html |

Categories

(Core :: DOM: Core & HTML, defect, P5)

defect

Tracking

()

RESOLVED INCOMPLETE

People

(Reporter: intermittent-bug-filer, Unassigned)

References

Details

(Keywords: intermittent-failure)

Filed by: apavel [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=171686479&repo=autoland

https://queue.taskcluster.net/v1/task/A1LNPAqLRoeZtefpD_l4xA/runs/0/artifacts/public/logs/live_backing.log

[task 2018-04-03T18:00:38.203Z] 18:00:38     INFO - TEST-START | /html/browsers/browsing-the-web/navigating-across-documents/javascript-url-abort/javascript-url-abort-return-value-string.tentative.html
[task 2018-04-03T18:00:38.252Z] 18:00:38     INFO - PID 4588 | [Parent 4588, Main Thread] WARNING: NS_ENSURE_TRUE(aSecondURI) failed: file /builds/worker/workspace/build/src/dom/base/ThirdPartyUtil.cpp, line 98
[task 2018-04-03T18:00:38.361Z] 18:00:38     INFO - PID 4588 | ++DOCSHELL 0x7efe5d0c6000 == 2 [pid = 4651] [id = {19f835dd-9cde-4e85-9e85-069d3bfd4fdb}]
[task 2018-04-03T18:00:38.361Z] 18:00:38     INFO - PID 4588 | ++DOMWINDOW == 5 (0x7efe644c4000) [pid = 4651] [serial = 5] [outer = (nil)]
[task 2018-04-03T18:00:38.409Z] 18:00:38     INFO - PID 4588 | ++DOMWINDOW == 6 (0x7efe644c4c00) [pid = 4651] [serial = 6] [outer = 0x7efe644c4000]
[task 2018-04-03T18:00:38.573Z] 18:00:38     INFO - PID 4588 | ++DOMWINDOW == 7 (0x7efe644c4800) [pid = 4651] [serial = 7] [outer = 0x7efe644c4000]
[task 2018-04-03T18:00:38.899Z] 18:00:38     INFO - PID 4588 | ++DOCSHELL 0x7efe5d0cf000 == 3 [pid = 4651] [id = {e233573c-083f-4f0d-8c87-a46cd6e9f55f}]
[task 2018-04-03T18:00:38.901Z] 18:00:38     INFO - PID 4588 | ++DOMWINDOW == 8 (0x7efe5cd40c00) [pid = 4651] [serial = 8] [outer = (nil)]
[task 2018-04-03T18:00:38.916Z] 18:00:38     INFO - PID 4588 | ++DOCSHELL 0x7efe5d0d2800 == 4 [pid = 4651] [id = {b632b4e5-118e-470f-8c63-b48a2c8c8811}]
[task 2018-04-03T18:00:38.916Z] 18:00:38     INFO - PID 4588 | ++DOMWINDOW == 9 (0x7efe5cd42000) [pid = 4651] [serial = 9] [outer = (nil)]
[task 2018-04-03T18:00:38.958Z] 18:00:38     INFO - PID 4588 | ++DOMWINDOW == 10 (0x7efe5cd43800) [pid = 4651] [serial = 10] [outer = 0x7efe5cd42000]
[task 2018-04-03T18:00:39.075Z] 18:00:39     INFO - PID 4588 | ++DOMWINDOW == 11 (0x7efe5cd47400) [pid = 4651] [serial = 11] [outer = 0x7efe5cd40c00]
[task 2018-04-03T18:00:39.096Z] 18:00:39     INFO - PID 4588 | ++DOMWINDOW == 12 (0x7efe5cd47c00) [pid = 4651] [serial = 12] [outer = 0x7efe5cd42000]
[task 2018-04-03T18:00:39.112Z] 18:00:39     INFO - PID 4588 | ++DOCSHELL 0x7efe5d0dd000 == 5 [pid = 4651] [id = {3ea3ac73-946f-47f2-9ae3-ee76acb843c0}]
[task 2018-04-03T18:00:39.113Z] 18:00:39     INFO - PID 4588 | ++DOMWINDOW == 13 (0x7efe5cd48800) [pid = 4651] [serial = 13] [outer = (nil)]
[task 2018-04-03T18:00:39.129Z] 18:00:39     INFO - PID 4588 | ++DOMWINDOW == 14 (0x7efe5cd4b800) [pid = 4651] [serial = 14] [outer = 0x7efe5cd48800]
[task 2018-04-03T18:00:40.323Z] 18:00:40     INFO - PID 4588 | ++DOMWINDOW == 15 (0x7efe592cbc00) [pid = 4651] [serial = 15] [outer = 0x7efe5cd48800]
[task 2018-04-03T18:00:40.464Z] 18:00:40     INFO - 
[task 2018-04-03T18:00:40.465Z] 18:00:40     INFO - TEST-UNEXPECTED-FAIL | /html/browsers/browsing-the-web/navigating-across-documents/javascript-url-abort/javascript-url-abort-return-value-string.tentative.html | Aborting fetch for javascript:string navigation - assert_false: child.childLoaded expected false got true
[task 2018-04-03T18:00:40.466Z] 18:00:40     INFO - @http://web-platform.test:8000/html/browsers/browsing-the-web/navigating-across-documents/javascript-url-abort/javascript-url-abort-return-value-string.tentative.html:20:9
[task 2018-04-03T18:00:40.466Z] 18:00:40     INFO - Test.prototype.step@http://web-platform.test:8000/resources/testharness.js:1494:20
[task 2018-04-03T18:00:40.467Z] 18:00:40     INFO - Test.prototype.step_func_done/<@http://web-platform.test:8000/resources/testharness.js:1534:17
[task 2018-04-03T18:00:40.467Z] 18:00:40     INFO - EventHandlerNonNull*onload/<@http://web-platform.test:8000/html/browsers/browsing-the-web/navigating-across-documents/javascript-url-abort/javascript-url-abort-return-value-string.tentative.html:19:55
[task 2018-04-03T18:00:40.468Z] 18:00:40     INFO - Test.prototype.step_timeout/<@http://web-platform.test:8000/resources/testharness.js:1552:20
[task 2018-04-03T18:00:40.468Z] 18:00:40     INFO - Test.prototype.step@http://web-platform.test:8000/resources/testharness.js:1494:20
[task 2018-04-03T18:00:40.469Z] 18:00:40     INFO - Test.prototype.step_func/<@http://web-platform.test:8000/resources/testharness.js:1518:20
[task 2018-04-03T18:00:40.470Z] 18:00:40     INFO - setTimeout handler*Test.prototype.step_timeout@http://web-platform.test:8000/resources/testharness.js:1551:16
[task 2018-04-03T18:00:40.471Z] 18:00:40     INFO - onload@http://web-platform.test:8000/html/browsers/browsing-the-web/navigating-across-documents/javascript-url-abort/javascript-url-abort-return-value-string.tentative.html:17:5
[task 2018-04-03T18:00:40.471Z] 18:00:40     INFO - EventHandlerNonNull*@http://web-platform.test:8000/html/browsers/browsing-the-web/navigating-across-documents/javascript-url-abort/javascript-url-abort-return-value-string.tentative.html:11:3
[task 2018-04-03T18:00:40.471Z] 18:00:40     INFO - Test.prototype.step@http://web-platform.test:8000/resources/testharness.js:1494:20
[task 2018-04-03T18:00:40.471Z] 18:00:40     INFO - async_test@http://web-platform.test:8000/resources/testharness.js:528:13
[task 2018-04-03T18:00:40.471Z] 18:00:40     INFO - @http://web-platform.test:8000/html/browsers/browsing-the-web/navigating-across-documents/javascript-url-abort/javascript-url-abort-return-value-string.tentative.html:10:1
[task 2018-04-03T18:00:40.472Z] 18:00:40     INFO - TEST-OK | /html/browsers/browsing-the-web/navigating-across-documents/javascript-url-abort/javascript-url-abort-return-value-string.tentative.html | took 2262ms
[task 2018-04-03T18:00:40.814Z] 18:00:40     INFO - PID 4588 | --DOCSHELL 0x7fa0018d2800 == 3 [pid = 4588] [id = {4dbfb48e-99c6-4351-b9d0-f926266482dc}]
[task 2018-04-03T18:00:40.837Z] 18:00:40     INFO - PID 4588 | --DOCSHELL 0x7fa0018d3000 == 2 [pid = 4588] [id = {e26d6772-ee41-47a2-a090-82b9d070dab1}]
[task 2018-04-03T18:00:40.875Z] 18:00:40     INFO - PID 4588 | 
[task 2018-04-03T18:00:40.875Z] 18:00:40     INFO - PID 4588 | ###!!! [Parent][RunMessage] Error: Channel closing: too late to send/recv, messages will be lost
[task 2018-04-03T18:00:40.875Z] 18:00:40     INFO - PID 4588 | 
[task 2018-04-03T18:00:40.875Z] 18:00:40     INFO - PID 4588 | [Child 4651, Main Thread] WARNING: NS_ENSURE_TRUE(maybeContext) failed: file /builds/worker/workspace/build/src/xpcom/threads/nsThread.cpp, line 809
[task 2018-04-03T18:00:40.883Z] 18:00:40     INFO - PID 4588 | [Child 4651, Main Thread] WARNING: Finishing incremental GC in progress during CC: file /builds/worker/workspace/build/src/xpcom/base/nsCycleCollector.cpp, line 3630
[task 2018-04-03T18:00:41.222Z] 18:00:41     INFO - PID 4588 | --DOCSHELL 0x7efe60da1800 == 4 [pid = 4651] [id = {3e2f73d9-9025-4ee2-8c6d-e103b4683ef2}]
[task 2018-04-03T18:00:41.223Z] 18:00:41     INFO - PID 4588 | --DOCSHELL 0x7efe5d0dd000 == 3 [pid = 4651] [id = {3ea3ac73-946f-47f2-9ae3-ee76acb843c0}]
[task 2018-04-03T18:00:41.223Z] 18:00:41     INFO - PID 4588 | --DOCSHELL 0x7efe5d0d2800 == 2 [pid = 4651] [id = {b632b4e5-118e-470f-8c63-b48a2c8c8811}]
[task 2018-04-03T18:00:41.224Z] 18:00:41     INFO - PID 4588 | --DOCSHELL 0x7efe5d0cf000 == 1 [pid = 4651] [id = {e233573c-083f-4f0d-8c87-a46cd6e9f55f}]
[task 2018-04-03T18:00:41.225Z] 18:00:41     INFO - PID 4588 | --DOCSHELL 0x7efe5d0c6000 == 0 [pid = 4651] [id = {19f835dd-9cde-4e85-9e85-069d3bfd4fdb}]
[task 2018-04-03T18:00:41.503Z] 18:00:41     INFO - PID 4588 | --DOCSHELL 0x7fa016308000 == 1 [pid = 4588] [id = {90ffc04f-f008-4a46-a309-510b2b402ad6}]
[task 2018-04-03T18:00:41.507Z] 18:00:41     INFO - PID 4588 | --DOCSHELL 0x7fa005255000 == 0 [pid = 4588] [id = {adbd254e-259d-4e95-9b92-ceb4f2e7fa27}]
[task 2018-04-03T18:00:41.528Z] 18:00:41     INFO - PID 4588 | 
[task 2018-04-03T18:00:41.529Z] 18:00:41     INFO - PID 4588 | ###!!! [Parent][RunMessage] Error: Channel closing: too late to send/recv, messages will be lost
Component: JavaScript Engine → DOM
Duplicate of this bug: 1451138
https://wiki.mozilla.org/Bug_Triage#Intermittent_Test_Failure_Cleanup
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → INCOMPLETE
Status: REOPENED → RESOLVED
Closed: 4 years ago4 years ago
Resolution: --- → INCOMPLETE
Component: DOM → DOM: Core & HTML
Status: RESOLVED → REOPENED
Resolution: INCOMPLETE → ---
Status: REOPENED → RESOLVED
Closed: 4 years ago3 years ago
Resolution: --- → INCOMPLETE
Status: REOPENED → RESOLVED
Closed: 3 years ago3 years ago
Resolution: --- → INCOMPLETE
Status: RESOLVED → REOPENED
Resolution: INCOMPLETE → ---
Status: REOPENED → RESOLVED
Closed: 3 years ago3 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.