Closed Bug 1451357 Opened 2 years ago Closed 2 years ago

Accessibility Shortcut toggles the DevTools Console when Accessibility is Disabled

Categories

(DevTools :: Accessibility Tools, defect)

defect
Not set

Tracking

(firefox61 fixed)

RESOLVED FIXED
Firefox 61
Tracking Status
firefox61 --- fixed

People

(Reporter: cade, Assigned: yzen)

Details

Attachments

(1 file)

This pushlog introduced some frontend bits for the Accessibility inspector tool: https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=ae5f6843bb631a32869fa29beb24a36498ed205a&tochange=4589600b540bd8cfedcaa5719f1e052a09fc0b8a (bug 1447112)

It configured a keyboard shortcut `Ctrl+Shift+Y` that toggles the tool, however, I noticed that when the tool is disabled in the developer tools settings, pressing this shortcut opens the web console.

This is also problematic for me because the BitWarden web extension uses this keyboard shorcut to toggle their popup menu, and this change clobbers that functionality: https://github.com/bitwarden/browser/blob/848117ff860fefce966825f34233b4afe63ca85d/src/manifest.json#L96
Duplicate of this bug: 1434888
Attached patch 1451357 patchSplinter Review
Removing the commandkey for now.
Attachment #8965028 - Flags: review?(pbrosset)
Assignee: nobody → yzenevich
Status: NEW → ASSIGNED
Attachment #8965028 - Flags: review?(pbrosset) → review+
Pushed by yura.zenevich@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/404bbf763428
removing accessibility commandkey that overlaps with some add-ons and a console on Windows. r=pbro
https://hg.mozilla.org/mozilla-central/rev/404bbf763428
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 61
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.