newlines in form fields (embedded 
)

RESOLVED WORKSFORME

Status

()

Core
HTML: Parser
RESOLVED WORKSFORME
16 years ago
11 years ago

People

(Reporter: Mark Daniel, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0rc2)
Gecko/20020510
BuildID:    2002051006 (Win2k)   2002051122 (OpenVMS)

Inside a form field value, for example

  <input TYPE=hidden NAME=title VALUE="&#10;&#10; -LOGGING-&#10;">

I use embedded, encoded newlines to add layout to submitted form content.  This
has always worked in Navigator (and does with MSIE) but is not honoured in
Mozilla.  Bug or feature?

Reproducible: Always
Steps to Reproduce:
1.  See example URL
2.  View HTML source.
3.  Hit submit button.
4.  View results.

Comment 1

16 years ago
jk and i looked at this and looks like the parser is removing the LF's from the
hidden's value. (checked in the dom inspector)
Assignee: alexsavulov → harishd
Status: UNCONFIRMED → NEW
Component: Form Submission → Parser
Ever confirmed: true
QA Contact: vladimire → moied

Updated

16 years ago
Priority: -- → P4

Comment 2

11 years ago
Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.9a6pre) Gecko/20070606 Minefield/3.0a6pre

This WORKSFORME on both Mac and Linux trunk. The line feeds are shown in the CGI dump and are also present in the DOMi values.

->WORKSFORME
Assignee: harishd → nobody
Keywords: qawanted
Priority: P4 → --
QA Contact: moied → parser

Updated

11 years ago
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.