auto updater changes language in windows control panel from de to en-US

RESOLVED DUPLICATE of bug 1436662

Status

()

RESOLVED DUPLICATE of bug 1436662
a year ago
a year ago

People

(Reporter: chanlists, Unassigned)

Tracking

59 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:59.0) Gecko/20100101 Firefox/59.0
Build ID: 20180323154952

Steps to reproduce:

Install firefox 59.0.1 (64-bit) german on Windows 10. 


Actual results:

The auto-updater updates to 59.0.2 and seems to correctly install a localized version in german. In the windows control panel, firefox is now shown as being installed in the en-US version. 


Expected results:

The control panel should show the de version to be installed even after an automatic update, as this confuses automatic software mangement engines.
I can reproduce this issue on my machine.  	Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:59.0) Gecko/20100101 Firefox/59.0

after the update the control panel shows en-US even though firefox is still running the DE locale.
Status: UNCONFIRMED → NEW
Component: Untriaged → Application Update
Ever confirmed: true
Product: Firefox → Toolkit
The locale name shown in the control panel comes from helper.exe, which isn't currently being localized properly.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1436662
You need to log in before you can comment on or make changes to this bug.