Context menu does not display correctly when viewing source of a message

RESOLVED FIXED in Thunderbird 61.0

Status

defect
RESOLVED FIXED
Last year
Last year

People

(Reporter: travis, Assigned: Paenglab)

Tracking

Thunderbird 61.0

Thunderbird Tracking Flags

(thunderbird60 fixed, thunderbird61 fixed)

Details

Attachments

(2 attachments)

Reporter

Description

Last year
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:59.0) Gecko/20100101 Firefox/59.0
Build ID: 20180327185825

Steps to reproduce:

When viewing the source of a message, the context menu does not appear correctly.

This is when using version Thunderbird 60.0b1 (64-bit) on Linux Mint 18.3 and Xfce 4.12. Also occurs under Safe Mode.


Actual results:

A menu appeared showing separators but the labels for "Find Again", "Copy", and "Select All" does not appear. Clicking where the options should be does not do anything.


Expected results:

The context menu should appear and function.
Assignee

Comment 1

Last year
I see this too.
Assignee: nobody → richard.marti
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Assignee

Comment 2

Last year
Some context menus didn't became expanded with labels etc. on port to c-c.
Attachment #8965417 - Flags: review?(jorgk)
Attachment #8965417 - Flags: approval-comm-beta?

Comment 3

Last year
Does "view source" work at all on trunk, I get
JavaScript error: chrome://messenger/content/viewSource.js, line 277: TypeError: wrapMenuItem is null

Comment 4

Last year
Comment on attachment 8965417 [details] [diff] [review]
viewSource.patch

Thanks, that restores the context menu.
Attachment #8965417 - Flags: review?(jorgk)
Attachment #8965417 - Flags: review+
Attachment #8965417 - Flags: approval-comm-beta?
Attachment #8965417 - Flags: approval-comm-beta+
Assignee

Updated

Last year
Keywords: checkin-needed

Comment 5

Last year
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/d2597729f2d8
Add missing context menuitem labels and commands. r=jorgk
Status: ASSIGNED → RESOLVED
Closed: Last year
Keywords: checkin-needed
Resolution: --- → FIXED

Updated

Last year
Target Milestone: --- → Thunderbird 61.0

Updated

Last year
Duplicate of this bug: 1454275
Component: Untriaged → Mail Window Front End
You need to log in before you can comment on or make changes to this bug.