Editing request type in "Edit and Resend" tab not working as expected

RESOLVED FIXED in Firefox 64

Status

defect
P3
normal
RESOLVED FIXED
a year ago
6 months ago

People

(Reporter: pradeepgangwar, Assigned: vi.le, Mentored)

Tracking

(Blocks 1 bug)

60 Branch
Firefox 64
Dependency tree / graph

Firefox Tracking Flags

(firefox64 fixed)

Details

Attachments

(2 attachments)

Posted video mozilla.mp4
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Firefox/60.0
Build ID: 20180402175344

Steps to reproduce:

After opening edit and resend tab I tried editing request type from GET to POST.


Actual results:

I was not able to completely delete GET from the text field.


Expected results:

Text field should be empty when we want to ALTER the request header.
I can reproduce this issue on my machine  	Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:61.0) Gecko/20100101 Firefox/61.0
Status: UNCONFIRMED → NEW
Component: Untriaged → Developer Tools: Netmonitor
Ever confirmed: true

Updated

a year ago
Product: Firefox → DevTools
Thanks for the report!

I can also reproduce it in my machine: Win10, Fx62 (Nightly)

There is also bug 1124698 that seems to be related.

For anyone interested in this bug.

1) Here is the place where the field value is updated:
https://searchfox.org/mozilla-central/rev/93d2b9860b3d341258c7c5dcd4e278dea544432b/devtools/client/netmonitor/src/components/CustomRequestPanel.js#119

2) Here is default value (`GET`):
https://searchfox.org/mozilla-central/rev/93d2b9860b3d341258c7c5dcd4e278dea544432b/devtools/client/netmonitor/src/components/CustomRequestPanel.js#222

It looks like the issue is somewhere around this code.

Honza
Mentor: odvarko
Priority: -- → P3
Assignee

Comment 3

8 months ago
Can I work on this? :-)

Vincent
Flags: needinfo?(odvarko)
Assigned to you!

Honza
Assignee: nobody → vi.le
Status: NEW → ASSIGNED
Flags: needinfo?(odvarko)
Assignee

Comment 5

8 months ago
Thank you. A question about UX, if the method field is empty, should we send the request with a empty method or should we do nothing?
Flags: needinfo?(odvarko)
(In reply to Vincent Lequertier from comment #5)
> Thank you. A question about UX, if the method field is empty, should we send
> the request with a empty method or should we do nothing?

We can reset the value to `GET` if the method field is empty on blur event (when it looses focus).
So, essentially use `GET` by default.

Honza
Flags: needinfo?(odvarko)
Assignee

Comment 8

8 months ago
> So, essentially use `GET` by default.

I tried to use the initial request method by default. So if the request was a "POST" before edit and resend and the field is empty, it will reset to "POST".
(In reply to Vincent Lequertier from comment #8)
> > So, essentially use `GET` by default.
> 
> I tried to use the initial request method by default. So if the request was
> a "POST" before edit and resend and the field is empty, it will reset to
> "POST".
I like that

Honza

Comment 10

8 months ago
Pushed by jodvarko@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0243cebc7b3c
Simplify edition of the "method" field in netmonitor edit and resend panel; r=Honza

Comment 11

8 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/0243cebc7b3c
Status: ASSIGNED → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 64
You need to log in before you can comment on or make changes to this bug.