Closed Bug 1451503 Opened 4 years ago Closed 4 years ago

Convert reftest extension from bootstrap to a webextension

Categories

(Testing :: Reftest, enhancement)

Version 3
enhancement
Not set
normal

Tracking

(firefox64 fixed)

RESOLVED FIXED
mozilla64
Tracking Status
firefox64 --- fixed

People

(Reporter: aswan, Assigned: aswan)

References

Details

Attachments

(3 files)

Depending on how much enthusiasm whoever ends up doing this has, some things could be modernized a bit or we could just do a quick-and-dirty conversion of the existing code to a WebExtension experiment.
Assignee: nobody → aswan
This can be squashed together with the next patch for landing but is
separated here for simpler reviewing.
:dbaron, I'm about to flag you for review on a couple of patches here since you're listed as the author of the reftest extension.  If you don't work on reftest any more, aren't interested in the details of the webextension conversion, or just don't have the bandwidth to review, please let me know and I'll find another reviewer.
Comment on attachment 9007116 [details]
Bug 1451503 Allow addonStartup.registerChrome() to register contentaccesible content packages

Kris Maglione [:kmag] has approved the revision.
Attachment #9007116 - Flags: review+
Comment on attachment 9007118 [details]
Bug 1451503 Convert reftest to a webextension

Kris Maglione [:kmag] has approved the revision.
Attachment #9007118 - Flags: review+
(In reply to Andrew Swan [:aswan] from comment #2)
> This can be squashed together with the next patch for landing but is
> separated here for simpler reviewing.

As long as they can both land alone without failures, might as well keep them separate. Smaller commits make it easier to find regressions/run blame.
(In reply to Andrew Swan [:aswan] from comment #4)
> :dbaron, I'm about to flag you for review on a couple of patches here since
> you're listed as the author of the reftest extension.  If you don't work on
> reftest any more, aren't interested in the details of the webextension
> conversion, or just don't have the bandwidth to review, please let me know
> and I'll find another reviewer.

I think it's better to find another reviewer for this one; this is the part of reftest that's been converted from one thing to another multiple times since I've written it...
Flags: needinfo?(aswan)
Will do, thanks for the reply.  As soon as I sort out the Android failures :/
Flags: needinfo?(aswan)
Comment on attachment 9007117 [details]
Bug 1451503 Move most reftest resources from chrome: to resource:

Kris Maglione [:kmag] has approved the revision.
Attachment #9007117 - Flags: review+
See Also: → 1492553
You need to log in before you can comment on or make changes to this bug.