Closed Bug 145156 Opened 20 years ago Closed 20 years ago

please add option for default xslt stylesheet for text/xml documents

Categories

(Core :: XML, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 64945

People

(Reporter: piersh, Assigned: hjtoi-bugzilla)

Details

It would be really nice if there was an option (not neccessarily UI) for
assigning a default XSL stylesheet to XML documents that don't specify a stylesheet.

Currently all you see when loading such an XML document is a blank page. I can't
imagine how this could be useful to anyone. Applying a default stylesheet would
make it easy to change this. For example, the default default could be a simple
stylesheet with a message, and developers wishing to see the structure of the
XML could format it how they wish...

IE renders XML documents in a collapsible tree using the following XSL stylesheet:
  http://msdn.microsoft.com/xml/samples/defaultss/defaultss.xsl

Nate Austin has converted this to W3C-conformant XSLT:
  http://www.dpawson.co.uk/xsl/sect2/microsoft.html#d156e206

This view is extremely useful when developing XML-based web services.
Maybe Bug 64945?
Yes, exactly.

*** This bug has been marked as a duplicate of 64945 ***
Status: UNCONFIRMED → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
QA Contact: petersen → rakeshmishra
You need to log in before you can comment on or make changes to this bug.