Closed Bug 1451570 Opened 2 years ago Closed 2 years ago

Links in Outlook Mail (outlook.com) closing message and returning to message list

Categories

(Core :: General, defect)

61 Branch
x86_64
Windows 10
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1433591

People

(Reporter: rivermikerat, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0
Build ID: 20180324220229

Steps to reproduce:

Reading email messages in outlook.live.com. Open message and move mouse around. No active links are detected. 


Actual results:

When a known active link is clicked, the message is closed and I am bumped back to the Inbox. 


Expected results:

I should have been able to click or right click the link and been taken to it.
Additional: Today is 4 April, 2018. Last night before bed Waterfox downloaded an upload. This morning this upload was loaded and installed. Yesterday Outlook worked fine. The new version of Waterfox is 56.1.0 (64-bit). I have tried Outlook in Chrome and Edge and have no problems. I have yet to try Firefox or Nightly.
OS: Unspecified → Windows 10
Hardware: Unspecified → x86_64
I can reproduce this issue on my machine  	Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:61.0) Gecko/20100101 Firefox/61.0

all links in emails navigate me back to the inbox.
Component: Untriaged → General
Product: Firefox → Core
Status: UNCONFIRMED → NEW
Ever confirmed: true
Provisionally marking as a Regression.
Keywords: regression
Version: 56 Branch → 61 Branch
Justin, is this happening in FFx60?
Flags: needinfo?(jwilliams)
This sounds a lot like Stylo bug 1387189, but that bug was found and fixed in Firefox 57.

I'm not able to reproduce in Firefox 59, Beta 60, or Nightly 61 on Windows 10.

Can you still reproduce this bug if you set pref "layout.css.servo.enabled" to false and restart Firefox?
That seems to have worked. Reset the layout.css setting and Outlook looks to be working properly.
NI Rares as Justin is no longer with SV.
Flags: needinfo?(jwilliams) → needinfo?(rares.bologa)
Flags: needinfo?(rares.bologa) → needinfo?(stefan.georgiev)
I tested this on Windows-10 with the latest nightly and could not manage to reproduce it. 

In outlook.live.com mail, links are detectable and when clicked, it opens in a new tab. 

Screen capture is here- https://testing-1.tinytake.com/sf/MjU2MTk3NV83NzA2Nzk5

Test Environment:
Version 	61.0a1
Build ID 	20180501102731
Update Channel 	nightly
User Agent 	Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:61.0) Gecko/20100101 Firefox/61.0c
Flags: needinfo?(stefan.georgiev)
Can you still reproduce?
Flags: needinfo?(rivermikerat)
Hey Mike, are you testing in Waterfox here? If so you need to report this to that crew, we don't work on that project @ Mozilla.
sounds like a dupe of bug 1433591 that got fixed in firefox 58.0.2
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Yes I can and yes I am. Where is the Waterfox group?
Flags: needinfo?(rivermikerat)
Resolution: FIXED → DUPLICATE
See Also: 1387189
Duplicate of bug: 1433591
You need to log in before you can comment on or make changes to this bug.